Cisco Nexus - vPC Command



 ◆ vPCの設定

 下図を前提にvPCの設定コマンドを解説します。なお、vPC Peer-Keepaliveリンクは、管理用の「mgmt0」
 インターフェースを使用することにして、管理ネットワークを経由しPeer-Keepaliveを行う構成となります。


   



 前提として、管理インターフェース(mgmt0)に以下の設定を行っているとします。


 
Nexus(config)# interface mgmt 0
 Nexus(config-if)# ip address 192.168.0.1/24
 Nexus(config-if)# no shutdown

 Nexus(config)# vrf context management
 Nexus(config-vrf)# ip route 0.0.0.0/0 192.168.0.254


 ※ NX-OS基本ライセンスではデフォルトVRFを使用できてmgmt0ポートには管理VRFを使用できる。2つのVRFは自動生成される。


 ◆ vPCドメインの設定

 
@ vPC機能のサービス有効化
 ⇒ デフォルトでは無効化されているため有効化する。
 (config)# feature vpc

 
A vPCドメインの設定
 ⇒ vPCピアスイッチで同じ値にする。
 (config)# vpc domain number

 
B vPC Roleの設定
 ⇒ vPCプライマリを値を小さく、vPCセカンダリを値を大きくする。
 (config-vpc-domain)# role priority number

 
C vPC Peer-Keepaliveの設定
 ⇒ destinationにvPCピアスイッチのアドレスを指定し、sourceに自身の送信元アドレスを指定する。
 (config-vpc-domain)# peer-keepalive destination address source address vrf management


 
Nexus(config)# feature vpc
 Nexus(config)# vpc domain 1
 Nexus(config-vpc-domain)# role priority 100
 Nexus(config-vpc-domain)# peer-keepalive destination 192.168.0.2 source 192.168.0.1 vrf management


 ※ vrf managemntはデフォルト設定であることからバージョンによって"show run"でも表示されない。




 ◆ vPCピアリンクの設定

 
@ vPCピアリンクとする物理インターフェースの指定
 (config)# interface ethernet interface

 
A トランクの設定
 (config-if)# switchport mode trunk
 (config-if)# switchport trunk allowed vlan vlan-id (必要に応じて )

 
B vPCピアリンクとする物理インターフェースの指定 ( LACP有効化が前提 )
 (config-if)# channel-group number mode active

 
C Bで指定したチャネルグループ番号のポートチャネルインターフェースの指定
 (config)# interface port-channel number

 D vPCピアリンクの指定
 (config-if)# vpc peer-link


 Nexus(config)# feature lacp

 
Nexus(config)# interface ethernet 1/1 - 2
 Nexus(config-if)# switchport mode trunk
 Nexus(config-if-range)# channel-group 1 mode active

 Nexus(config)# interface port-channel 1
 Nexus(config-if)# vpc peer-link

 ※ vpc peer-linkの設定を行うと、そのinterface port-channelに自動的に spanning-tree port type network が設定されます。


 ◆ vPCメンバーポートの設定

 
@ vPCメンバーポートの指定
 (config)# interface ethernet interface

 
A チャネルグループ番号の設定
 (config-if)# channel-group number mode [ on | active | passive ]

 
B Aで指定したチャネルグループ番号のポートチャネルインターフェースの指定
 (config)# interface port-channel number

 
C vPCメンバー番号の設定
 (config-f)# vpc number


 
Nexus(config)# interface ethernet 1/3
 Nexus(config-if)# channel-group 10 mode active

 Nexus(config)# interface port-channel 10
 Nexus(config-if-range)# vpc 10




 ◆ vPC - Peer-Keepaliveリンクの特徴

 @ セカンダリチェックとしてのvPCピア間の生存確認
 A UDP:3200番号を使用して96バイト長のメッセージとして送信される。
 B キープアライブメッセージは1秒間隔で送信されタイムアウトは5秒。ピアリンクは3秒のHold Timeout。
 C Peer-Keepaliveリンクは専用リンク(1G)とすることが推奨。(Peerリンク上で転送しないようにする)
 D Peer-Keepaliveリンクのためにmgmt0インターフェースの使用が推奨。管理トラフィックと混在してOK。
 E Peer-Keepaliveリンクを同一セグメントとして構成するのが望ましいが、異なるセグメントでも通信可能。
 F Peer-Keepaliveリンクの例えば mgmt0インターフェース同士を直結せずに間に機器をはさむことが推奨。




 ◆ vPC - Peerリンクの特徴

 @ Peerリンクは、最低10GE×2の物理インターフェースで構成することが推奨。(10GEの使用は必須要件)
 A Peerリンク間は直結させる必要がある。vPCピア間においても他のデバイスを挿入してはいけない。
 B Peerリンクは、802.1Qトランクで構成する。(そのトランク上に、vPCとnon vPC VLANが転送される)
 ※ Cisco Favric ServicesメッセージだけでなくSTPのBPDUやHSTP Hello等の各種プロトコルも転送される。




 ◆ vPC - 障害発生時の動作

 @ vPCプライマリスイッチがダウンした場合(電源OFF状態)、全てのトラフィックはセカンダリ経由で転送。
 A vPCセカンダリスイッチがダウンした場合(電源OFF状態)、瞬断が発生するものの正常に通信を継続。
 B Peerリンクに障害発生した場合、vPCメンバポートをsuspededにしプライマリ側のパスのみを使用する。
 C Peer-Keepaliveリンクに障害発生した場合、Peerリンクが正常であればスイッチとして動作を継続する。
 D Peer-KeepaliveリンクとPeerリンクの両方に障害が発生した場合(つまり二重障害が発生した場合)は
   vPCセカンダリスイッチはvPCプライマリスイッチの状態を確認できないため両方がプライマリとして動作。
 ⇒ これによりネットワークシステム全体が不安定になってしまうため念のために裏でSTP等を有効化する。

 ※ ちなみに、vPCではpreemptはサポートされていません。



 ◆ vPC - その他の重要な設定

 
◆ vPCにおけるバックアップメカニズムの提供 (L2/L3推奨)
 
⇒ vPCピアリンクのダウンの発生時にPrimaryスイッチがダウンするという二重障害が発生してもSecondaryスイッチは正常に動作

 Nexus(config)# vpc domain 1
 
Nexus(config-vpc-domain)# auto-recovery



 
◆ 2台のvPCスイッチが同じルート情報を送信する設定 (L2/L3推奨) ※ vPC+構成でPeer Switchの設定は推奨ではありません。
 
⇒ ピアスイッチに障害が発生しても通信切断が発生しなくなる。

 Nexus(config)# vpc domain 1
 
Nexus(config-vpc-domain)# peer-switch



  着信パケットの宛先MACがそのvPCピアスイッチのMACである場合、ローカル(Nexus)で転送可能にする設定(L3推奨)


 Nexus(config)# vpc domain 1
 
Nexus(config-vpc-domain)# peer-gateway


 ◆ ピアスイッチ障害後の復旧時、vPCピアスイッチ間のARP情報を同期させる設定 (L3推奨)
 
⇒ ARP解決の遅延が発生せず、Nexusスイッチを介するL3トラフィックの収束時間が改善する。

 Nexus(config)# vpc domain 1
 
Nexus(config-vpc-domain)# ip arp synchronize




Cisco Nexus - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2017 ネットワークエンジニアとして All Rights Reserved.