LLQ ( Low-Latency Queuing )



 ◆ LLQ(Low-Latency Queuing)とは

 LLQは、CBWFQのキューイング方式にPQのキューイング方式を追加したキューイング技術のことです。
 LLQではCBWFQのように各キューの帯域幅を保証しながらも、PQのように特定トラフィックを最優先
 処理させることができます。現在の企業ネットワークで最も主流なQoSのキューイング技術と言えます。


   


 CBWFQの場合は各キューごとに最低保証帯域を定義しましたが、LLQにより追加されるPQのキューでは
 そのキューに格納される全てのパケットは最優先処理されて転送されることから、インターフェース上で
 利用可能な帯域を
絶対優先キューPriorityキュー)だけで使い果たさないように絶対優先キューで利用
 
できる帯域幅を制限できます。なお、一般的に音声関連のトラフィックをPriorityキューに格納させます。



  


 LLQを実装させることによって、
輻輳時にPriorityキューに格納されたパケットは最優先処理されながらも、
 他のキューに格納されたパケットは、bandwidthコマンドによって最低保証帯域幅を確保して処理されます。


 ◆ LLQ - Ciscoルータのコンフィグ設定

 LLQのコンフィグ設定は、CBWFQの設定に加えてpriorityキュー用として、policy-mapのコンフィグ設定に
 以下の「
priority」コマンドの設定でPQを有効化させるだけです。※ 事前にCBWFQの設定をご参照下さい。

 ◆ 絶対優先キュー(Priorityキュー)の設定
 (config)#
policy-map name
 (config-pmap)#
class-map name
 (config-cmap-c)# priority bandwidth-kbps [ burst ]
 or
 (config-cmap-c)#
priority percent percentage [ burst ]

コマンド引数 説明
bandwidth-kbps

 絶対優先キューで利用可能な最大帯域幅を「kbps」単位で指定。

burst

 オプション設定。burstサイズを「bytes」単位で指定。


コマンド引数 説明
percentage

 絶対優先キューで利用可能な最大帯域幅を「%」単位で指定。

burst

 オプション設定。burstサイズを「bytes」単位で指定。




 ◆ LLQ - Ciscoルータのコンフィグ設定例

 設定例ではシンプルにACL101の通信が音声トラフィックが流れるネットワークセグメントを定義して、
 ACL102とACL103はデータトラフィックが流れるセグメントとして、
輻輳時に、音声トラフィックでは
 遅延なく最優先処理してFa0/0から転送されるようにLLQを実装させています。定義した全てのクラスに
 合致しなかったトラフィックは「class-default」のキューにてWFQのキューイング処理で転送されます。


 Cisco(config) #
access-list 101 permit ip 192.168.1.0 0.0.0.255 10.1.0 0.0.255.255
 Cisco(config) # access-list 102 permit ip 192.168.2.0 0.0.0.255 10.2.0 0.0.255.255
 Cisco(config) # access-list 103 permit ip 192.168.3.0 0.0.0.255 10.3.0 0.0.255.255


 Cisco(config) # class-map match-any C-VOICE
 Cisco(config-cmap) # match access-group 101

 Cisco(config) # class-map C-DATA2
 Cisco(config-cmap) # match access-group 102

 
Cisco(config) # class-map C-DATA3
 
Cisco(config-cmap) # match access-group 103


 Cisco(config) # policy-map P-RULE1
 
Cisco(config-pmap) # class C-VOICE
 Cisco(config-pmap-c) # priority percent 10
 Cisco(config-pmap) # class C-DATA2
 Cisco(config-pmap-c) # bandwidth percent 25
 
Cisco(config-pmap) # class C-DATA3
 
Cisco(config-pmap-c) # bandwidth percent 25
 Cisco(config-pmap) # class class-default
 
Cisco(config-pmap-c) # fair-queue

 Cisco(config) # interface FastEthernet0/0
 
Cisco(config-if) # service-policy output P-RULE1


 
show policy-map interface FastEthernet0/0 で LLQのステータス確認(重要な確認コマンド)を行います。

 以下の設定例は、現在では見られなくなった設定ですが、FrameRelayなど64kbpsという狭い帯域において
 CiscoのVoIP機器から発生する音声トラフィックに合致するトラフィックをPriorityキューで処理させて、その
 Priorityキューの最大使用可能な帯域幅を「45kbps」に指定しています。また、TCP:1720(H.323/H.225)
 に合致するトラフィックは最低保証帯域幅を「8kbps」としています。※ QoS部分のコンフィグだけを抜粋。


 Cisco(config) #
access-list 101 permit udp any any range 16384 32767
 Cisco(config) # access-list 102 permit tcp any eq 1720 any
 Cisco(config) # access-list 102 permit tcp any any eq 1720


 Cisco(config) # class-map C-VOICE
 Cisco(config-cmap) # match access-group 101

 Cisco(config) # class-map C-SIGNAL
 Cisco(config-cmap) # match access-group 102


 Cisco(config) # policy-map P-RULE1
 
Cisco(config-pmap) # class C-VOICE
 Cisco(config-pmap-c) # priority 45
 Cisco(config-pmap) # class C-SIGNAL
 Cisco(config-pmap-c) # bandwidth 8
 Cisco(config-pmap) # class class-default
 Cisco(config-pmap-c) # fair-queue

 Cisco(config) # interface Serial0/0
 
Cisco(config-if) # service-policy output P-RULE1


 VoIPゲートウェイのCiscoルータで定義する音声トラフィック合致のための設定例として、ACL101の代わりに
 class-mapで「match ip rtp 16384 16383」or「match ip precedence 5」or「match ip dscp ef」と定義
 したとしても、音声トラフィックの合致条件となります。



QoS

ネットワークエンジニアとして

Copyright (C) 2002-2017 ネットワークエンジニアとして All Rights Reserved.