IP Precedence



 ◆ IP Precedence(IPプレシデンス)とは

 IPプレシデンスとは、IPヘッダの中のToSフィールドで定義されたIPパケットの優先度を表す値のことです。
 IPプレシデンス値は「 0 」〜「 7 」の8段階あります。値が大きいほどその優先度が高いことを意味します。

 Ethernet LANでTCP/IPを通信する場合、当然ながらそのフレームには20byteのIPヘッダが付加されます。
 そして、その20byteのIPヘッダの詳細を見ると、8bitのToS(Type of Service)と呼ばれるフィールドが
 あります。IPプレシデンスでは、その中の3bitを使用して8段階( 0〜7 )で優先度を表すことができます。


   


 PCから送信されるIPパケットは一般的にIPプレシデンスの値は「0」として送出されるのに対して、IP電話
 などの音声機器から送信されるIPパケットは一般的に「3」や「5」の値が付加されて送出されます。なお、
 これらのIPパケットを通過するルータでIPプレシデンス値を、ルータの設定で書き換えすることが可能です。


 ◆ IP Precedence - 8つのクラス

 IPプレシデンスには以下の通り8段階あります。IPプレシデンス値は高い値ほど優先度が高くなります。
 IPプレシデンス 7(Network control)とIPプレシデンス6(Internetwork control)は、ルーティング
 パケットや制御パケットなどネットワーク制御用に予約済みであり、ネットワーク管理者が設定する場合
 
IPプレシデンス値の「0 〜 5」の値を使用して設計する必要があります。

IPプレシデンス値 bit IP Precedence
7 111 Network control
6 110 Internetwork control
5 101 Critical
4 100 Flash override
3 011 Flash
2 010 Immediate
1 001 Priority
0 000 Routine




 ◆ IPプレシデンス値の設定 - PBRによる設定

 レガシーな設定方法としてPBRによるマーキングがあります。以下の設定により、172.16.1.1を宛先とする
 全てのIPトラフィックにIP Precedence 5(critical)を割り当てる結果となります。ACL101に合致しない
 他のIPトラフィックに関しては、そのパケットの持つPrecedence値のままで転送されていくことになります。


 Cisco(config) #
access-list 101 permit ip any host 172.16.1.1

 
Cisco(config) # route-map R-MARK permit 10
 Cisco(config-route-map) # match ip address 101
 Cisco(config-route-map) # set ip precedence critical

 Cisco(config) # interface GigabitEthernet0/0
 
Cisco(config-if) # ip policy route-map R-MARK




 ◆ IPプレシデンス値の設定 - Class-Basedパケットマーキングによる設定

 現在の主流な設定方法として、Class-Basedパケットマーキングがあります。この設定を行うためには
 グローバルで「
ip cef 」が有効である必要があります。以下の設定によって、172.16.1.1を宛先とする
 全てのIPトラフィックにIP Precedence 5(critical)が割り当てられます。なお、ACL101に合致しない
 他のIPトラフィックは、そのパケットの持つIP Precedence値のままで転送されていくことになります。


 Cisco(config) #
ip cef
 Cisco(config) # access-list 101 permit ip any host 172.16.1.1

 Cisco(config) # class-map match-all C-MARK
 Cisco(config-cmap) # match access-group 101

 
Cisco(config) # route-map R-MARK permit 10
 Cisco(config-pmap) # class C-MARK
 Cisco(config-pmap-c) # set ip precedence 5

 Cisco(config) # interface GigabitEthernet0/0
 
Cisco(config-if) # service-policy input P-mark




QoSをはじめから

ネットワークエンジニアとして

Copyright (C) 2002-2017 ネットワークエンジニアとして All Rights Reserved.