route-map - redistribute



 ◆ redistributeコマンドにroute-mapを適用した設定

 ルートマップをルート再配布(redistribute)の設定に適用してフィルタリングする設定は以下となります。

 ◆ ルートマップの設定
 (config)# route-map map-tag permit | deny [ seq-number ]
 (config-route-map)#
match condition
 (config-route-map)#
set action

 
◆ ルートマップを適用するためのルート再配布の設定
 (config)#
router protocol
 (config-router)#
redistribute protocol route-map map-tag

matchコマンド 説明
 match ip address acl

 ルート再配布における対象ルートの合致条件に、ACLを使用

 match ip address prefix-list name  ルート再配布における対象ルートの合致条件に、Prefixを使用
 match interface interface-id  ルート再配布における合致条件に、interfaceを使用
 match tag name  ルート再配布における合致条件に、TAGを使用
 match metric metric  ルート再配布における合致条件に、メトリックを使用
 match route-type type  ルート再配布における合致条件に、ルートタイプを使用
 match ip next-hop acl  標準ACLで定義したアドレスのネクストホップとなっているルートが再配布対象
 match ip route-source acl  標準ACLで定義したアドレスのソースアドレスを持つルータのルートが再配布対象


 
上記で紹介したmatch route-typeコマンド指定するルートタイプには以下のようなものがあります。
 
(config-route-map)# match route-type local | internal | external [ type1 | type2 ] nssa-external

match route-typeコマンド 説明
 local

 ローカルに生成されたBGPルート

 internal  OSPFの内部ルート( エリア内ルート、エリア間ルート )
 external  OSPFの外部ルート、または、EIGRPの外部ルート
 external type 1  OSPFのタイプ 1 外部ルートにのみ一致
 external type 2  OSPFのタイプ 2 外部ルートにのみ一致
 nssa-external  OSPFのNSSAの外部ルート

setコマンド 説明
 set metric value

 matchコマンドの合致ルートに、ルートメトリック値を定義

 set metric-type value  matchコマンドの合致ルートに、再配布先のルーティングプロトコルのメトリックタイプを定義。
 set tag tag

 matchコマンドの合致ルートに、タグ値を定義



 ◆ redistributeコマンドにroute-mapを適用した設定の理解

 以下の「1」と「2」の違いを理解することで、route-mapによるフィルタリング設定の理解が深まります。
 ルートフィルタリングを実行するだけなら、以下の1と2ともに設定方法が違うだけで同じ結果が得られます。
 1と2の違いは、2では例えば
ルートごとにメトリック値やメトリックタイプなどを柔軟に定義できる点です。

 1. redistributeコマンド + distribute-listコマンドによるフィルタリング
 2. redistributeコマンド + route-mapコマンドによるフィルタリング

 先ず以下の設定例を見て、ルートフィルタリングするだけなら「1」と「2」は同じ動作を実現できることを
 理解しましょう。以下では「192.168.1.0/24」以外のEIGRPルートを、OSPFへルート再配布する設定です。

 
◆ redistributeコマンド + distribute-listコマンドによるフィルタリング

 Cisco(config)# access-list 1 deny 192.168.1.0 0.0.0.255
 Cisco(config)# access-list 1 permit any

 Cisco(config)# router ospf 1
 Cisco(config-router)# redistribute eigrp 1 subnets
 Cisco(config-router)# distribute-list 1 out eigrp 1



 ◆ redistributeコマンド + route-mapコマンドによるフィルタリング

 Cisco(config)# access-list 1 deny 192.168.1.0 0.0.0.255
 Cisco(config)# access-list 1 permit any

 Cisco(config)# route-map R-FILT01 permit 10
 Cisco(config-route-map)# match ip address 1

 Cisco(config)# router ospf 1
 Cisco(config-router)# redistribute eigrp 1 subnets route-map R-FILT01




 ◆ redistributeコマンドにroute-mapを適用した設定例

 以下の設定例により、route-mapの設定を利用するならではの、以下の要件を満たせることができます。

 ・ 192.168.1.0/24のEIGRPルートには、OSPFネットワークへの再配布時にメトリックタイプ1を定義
 ・ 192.168.2.0/24のEIGRPルートには、OSPFネットワークへの再配布時にメトリック値を100に定義
 ・ それ以外のすべてのルートは、メトリックタイプもメトリック値もデフォルトの状態でルート再配布


 Cisco(config)# ip prefix-list PRE01 permit 192.168.1.0/24
 Cisco(config)# ip prefix-list PRE02 permit 192.168.2.0/24

 Cisco(config)# route-map R-FILT01 permit 10
 Cisco(config-route-map)# match ip address prefix-list PRE01
 Cisco(config-route-map)# set metric-type type-1

 Cisco(config)# route-map R-FILT01 permit 20
 Cisco(config-route-map)# match ip address prefix-list PRE02
 Cisco(config-route-map)# set metric 100

 Cisco(config)# route-map R-FILT01 permit 30

 Cisco(config)# router ospf 1
 Cisco(config-router)# redistribute eigrp 1 subnets route-map R-FILT01




ルート再配布とルート制御( redistribute、distribute-list、route-map、distance )

ネットワークエンジニアとして

Copyright (C) 2002-2024 ネットワークエンジニアとして All Rights Reserved.