Traffic shaping for Data / Voice - QoS config



 ※ 以下を読む前に QoS - WANでのシェーピング for ボイス/データトラフィック をお読み下さい。


 ◆ ACLに基づいた拠点ごとのトラフィックシェーピング - 階層型QoSの実装

 1対NのWAN構成である場合、センター拠点にトラフィックが集中するとパケットドロップが発生することも
 あるので、センター拠点ではWAN回線契約時にQoSオプションを申し込むことで、優先トラフィックを保護
 することも可能ですが、ACLに基づいた拠点ごとのトラフィックシェーピングの実装により、その問題を回避
 することも可能です。以下で紹介する設定例は「拠点Aと拠点B間の通信は発生しないこと」を前提とします。


    


 
◆ 設定例 : CE1 - 設定順序は @分類、Aマーキング、Bキューイング & スケジューリング

 Cisco(config)# ip cef

 Cisco(config)# access-list 101 permit ip host 172.16.1.100 any
 Cisco(config)# access-list 102 permit ip host 172.16.1.200 any

 Cisco(config)# class-map match-all C-VOICE
 Cisco(config-cmap)# match access-group 101

 Cisco(config)# class-map match-all C-KANRI
 Cisco(config-cmap)# match access-group 102

 Cisco(config)# policy-map P-MARK
 Cisco(config-pmap)# class C-VOICE
 Cisco(config-pmap-c)# set dscp ef

 Cisco(config-pmap)# class C-KANRI
 Cisco(config-pmap-c)# set dscp af31

 Cisco(config)# interface FastEthernet 0/1
 Cisco(config-if)# service-policy input P-MARK


 Cisco(config)# class-map match-all C-EF
 Cisco(config-cmap)# match dscp ef

 Cisco(config)# class-map match-all C-AF31
 Cisco(config-cmap)# match dscp af31

 Cisco(config)# policy-map P-CHILD
 Cisco(config-pmap)# class C-EF
 Cisco(config-pmap-c)# priority percent 25
 Cisco(config-pmap)# class C-AF31
 Cisco(config-pmap-c)# bandwidth percent 10
 
Cisco(config-pmap)# class class-default
 
Cisco(config-pmap-c)# fair-queue


 Cisco(config)# access-list 111 permit ip any 172.16.1.0 0.0.0.255
 Cisco(config)# access-list 112 permit ip any 172.16.2.0 0.0.0.255

 Cisco(config)# class-map match-all C-CE2
 Cisco(config-cmap)# match access-group 111

 Cisco(config)# class-map match-all C-CE3
 Cisco(config-cmap)# match access-group 112

 Cisco(config)# policy-map P-PARENT
 Cisco(config-pmap)# class C-CE2
 Cisco(config-pmap-c)# shape average 15000000
 
Cisco(config-pmap-c)# service-policy P-CHILD
 Cisco(config-pmap)# class C-CE3
 Cisco(config-pmap-c)# shape average 15000000
 
Cisco(config-pmap-c)# service-policy P-CHILD

 Cisco(config)# interface FastEthernet 0/0
 Cisco(config-if)# service-policy output P-PARENT


 要件1 : 本社から拠点Aとの通信帯域を15Mbpsにシェーピング、拠点Bとの通信帯域を15Mbpsにシェーピングする。
 要件2 : 音声トラフィックのDSCP値を46、管理トラフィックをDSCP値を26にマーキングしデータトラフィックはDSCP値0のままに。
 要件3 : 音声トラフィック(アドレスの第4オクテット .200)を最優先処理(25%上限)してパケットを送出。
 要件4 : 管理トラフィック(アドレスの第4オクテット .100)の帯域保証(10%保証)を行う。他のトラフィックは class-default へ。

 ※ policy-map CHILD(子ポリシー)を、policy-map PARENT(親ポリシー)上でサービス適用することで階層型QoSの実装となる。


 ◆ 設定例 : CE2 - 設定順序は @分類、Aマーキング、Bキューイング & スケジューリング


 Cisco(config)# ip cef

 Cisco(config)# access-list 101 permit ip host 172.16.2.100 any
 Cisco(config)# access-list 102 permit ip host 172.16.2.200 any

 Cisco(config)# class-map match-all C-VOICE
 Cisco(config-cmap)# match access-group 101

 Cisco(config)# class-map match-all C-KANRI
 Cisco(config-cmap)# match access-group 102

 Cisco(config)# policy-map P-MARK
 Cisco(config-pmap)# class C-VOICE
 Cisco(config-pmap-c)# set dscp ef

 Cisco(config-pmap)# class C-KANRI
 Cisco(config-pmap-c)# set dscp af31

 Cisco(config)# interface FastEthernet 0/1
 Cisco(config-if)# service-policy input P-MARK


 Cisco(config)# class-map match-all C-EF
 Cisco(config-cmap)# match dscp ef

 Cisco(config)# class-map match-all C-AF31
 Cisco(config-cmap)# match dscp af31

 Cisco(config)# policy-map P-CHILD
 Cisco(config-pmap)# class C-EF
 Cisco(config-pmap-c)# priority percent 25
 Cisco(config-pmap)# class C-AF31
 Cisco(config-pmap-c)# bandwidth percent 10
 
Cisco(config-pmap)# class class-default
 
Cisco(config-pmap-c)# fair-queue

 Cisco(config)# policy-map P-PARENT
 Cisco(config-pmap)# class class-default
 Cisco(config-pmap-c)# shape average 15000000
 
Cisco(config-pmap-c)# service-policy P-CHILD

 Cisco(config)# interface FastEthernet 0/0
 Cisco(config-if)# service-policy output P-PARENT




 ステータス確認コマンド ⇒ show access-lists / show class-map / show policy-map / show policy-map interface



QoS - WANでのシェーピング

ネットワークエンジニアとして

Copyright (C) 2002-2017 ネットワークエンジニアとして All Rights Reserved.