BGP - loopback I/F IBGP / EBGP



 ◆ BGP - loopbackインターフェースを使用したIBGPピア接続

 IBGPピア接続する時は一般的にネイバーアドレスに
loopbackI/Fを指定します。特定の物理I/FのIPアドレス
 を指定しないことにより、冗長リンク構成においては一方の物理I/FがダウンしてもBGP接続を維持できます。

 loopback I/FをネイバーIPアドレスとして指定する時に設定上の注意点があります。下図の通りBGPネイバー
 を確立する際に、BGPメッセージを送信する際に
送信元アドレスは出力インターフェースのIPアドレスを使用
 します。また、
宛先アドレスはneighbor remote-asコマンドで指定したアドレスをデフォルトで使用します。


   


 BGPメッセージを受信したBGPルータは、BGPメッセージに含まれた送信元IPアドレスと、自身の設定上の
 neighbor remote-as コマンドで指定した宛先IPアドレスを比較して、一致した場合にBGPネイバーを確立
 します。従って、物理インターフェースをneighbor remote-asで指定する場合には、問題は発生しません。

 しかし、neighbor remote-asコマンドでloopback I/FのIPアドレスを指定しても、BGPメッセージに中の
 送信元アドレスは物理インターフェースのままであるため、双方のアドレスが一致せずBGPネイバーが確立
 できません。そこで、
neighbor update-sourceコマンドを使用します。この設定によりBGPメッセージに
 含まれた送信元アドレスを指定したI/Fのアドレスに変更できるので、双方のアドレスを一致させられます。

 以下はloopback I/Fのアドレスを使用したIBGPピア接続の設定例となります。通常、AS内ではIGPが実行
 されており、loopback I/F、物理 I/F のセグメントがOSPFにてアドバタイズされている前提の設定例です。

 ◆ BGP - loopbackインターフェースを使用したIBGPピア接続

 R1(config)# interface loopback0
 R1(config-if)# ip address 10.1.1.1 255.255.255.255

 R1(config)# router ospf 1
 R1(config-router)#network 10.1.1.1 0.0.0.0 area 0
 R1(config-router)#network 192.168.1.1 0.0.0.0 area 0
 R1(config-router)#network 192.168.2.1 0.0.0.0 area 0

 R1(config)# router bgp 10
 R1(config-router)#neighbor 10.2.2.2 remote-as 10
 R1(config-router)#neighbor 10.2.2.2 update-source loopback 0


 R2(config)# interface loopback0
 R2(config-if)# ip address 10.2.2.2 255.255.255.255

 R2(config)# router ospf 1
 R2(config-router)#network 10.2.2.2 0.0.0.0 area 0
 R2(config-router)#network 192.168.1.2 0.0.0.0 area 0
 R2(config-router)#network 192.168.2.2 0.0.0.0 area 0

 R2(config)# router bgp 10
 R2(config-router)#neighbor 10.1.1.1 remote-as 10
 R2(config-router)#neighbor 10.1.1.1 update-source loopback 0



 ◆ BGP - loopbackインターフェースを使用したEBGPピア接続

 上述の技術解説は、EBGPピア接続においても適用できるため、EBGPピア接続でもloopback I/F を使用して
 ネイバーを確立する場合、
update-sourceコマンドを使用します。また、EBGPピアにおけるBGPメッセージ
 のTTLは「1」であること点も意識した設定が必要です。loopback I/Fのアドレスは直接接続のネットワーク
 ではないことから、
ebgp-multihopコマンドで、TTLの値を「1」よりも大きな値に変更する必要があります。


   



 AS内ではIGPを使用しますが、AS間でIGPを使用することは先ずなく、例えばスタティックルートにより
 loopbackインターフェースのアドレスに対するIP到達性を確立させておく必要があります。

 ◆ BGP - loopbackインターフェースを使用したEBGPピア接続

 R1(config)# interface loopback0
 R1(config-if)# ip address 1.1.1.1 255.255.255.255

 R1(config)#ip route 2.2.2.2 255.255.255.255 1.0.0.1
 R1(config)#ip route 2.2.2.2 255.255.255.255 1.0.1.1

 R1(config)# router bgp 1
 R1(config-router)#neighbor 2.2.2.2 remote-as 2
 R1(config-router)#neighbor 2.2.2.2 update-source loopback 0
 R1(config-router)#neighbor 2.2.2.2 ebgp-multihop 2


 R2(config)# interface loopback0
 R2(config-if)# ip address 2.2.2.2 255.255.255.255

 R2(config)#ip route 1.1.1.1 255.255.255.255 1.0.0.2
 R2(config)#ip route 1.1.1.1 255.255.255.255 1.0.1.2

 R2(config)# router bgp 2
 R2(config-router)#neighbor 1.1.1.1 remote-as 1
 R2(config-router)#neighbor 1.1.1.1 update-source loopback 0
 R2(config-router)#neighbor 1.1.1.1 ebgp-multihop 2




BGP(Border Gateway Protocol)

ネットワークエンジニアとして

Copyright (C) 2002-2020 ネットワークエンジニアとして All Rights Reserved.