Catalyst 4500X - VSS - config 1



 ◆ Catalyst4500-X VSSの設定 - 必須

 
01. sh version でバージョンの確認(IOS XE 3.4.0SG / IOS 15.1(2) SG以降であることを確認)
 
⇒ 以降のコンフィグは、IOS-XE 3.5.0E/IOS 15.2(1) cat4500e-universalk9.SPA.03.05.00.E.152-1.E.binにおける解説。

 
02. Virtual Switch Domain と Virtua Switch Numbersの設定
 You must configure the same virtual switch domain number on both switches of the VSS. The virtual switch domain
 is a number between 1 and 255, and must be unique for each VSS in your network (the domain number is incorporated
 into various identifiers to ensure that these identifiers are unique across the network).

 
◆ SW1 の設定

 
SW1(config)# switch virtual domain 100
 SW1(config-vs-domain)# switch 1


 ◆ SW2 の設定

 
SW2(config)# switch virtual domain 100
 SW2(config-vs-domain)# switch 2


 ◆ 出力されるメッセージ


 Domain ID 100 config will take effect only
 after the exec command 'switch convert mode virtual' is issued



 03. VSLポートチャネルとポート設定
 
The VSL is configured with a unique port channel on each switch. During the conversion, the VSS configures both port
 channels on the VSS active switch. If the VSL port channel on the VSS standby switch has been configured for other use,
 the VSS comes up in RPR mode. So, check that both port channel numbers are available on both of the switches.

 ◆ SW1 の設定

 
SW1(config)# interface port-channel 1
 SW1(config-if)# switchport
 SW1(config-if)# switch virtual link 1
 SW1(config-if)# no shutdown


 ◆ SW2 の設定

 
SW2(config)# interface port-channel 2
 SW2(config-if)# switchport
 SW2(config-if)# switch virtual link 2
 SW2(config-if)# no shutdown


 次にポートチャネルへVSL物理ポートをアサイン。VSLインターフェースのChannelモードはonのみサポート。

 ◆ SW1 の設定

 
SW1(config)# interface range TenGigabitEthernet 1/1 - 2
 SW1(config-if-range)# channel-group 1 mode on


 ◆ SW2 の設定

 
SW2(config)# interface range TenGigabitEthernet 1/1 - 2
 SW2(config-if-range)# channel-group 2 mode on


 上記設定を行った時点で、自動的に物理I/Fに以下のコンフィグ設定と膨大なQoS設定が追加されます。
 
※ バージョンによって自動的に追加されるコンフィグ設定が異なります。念のため「 sh run all 」でも確認しましょう。

 
switchport mode trunk
 
switchport nonegotiate
 no lldp transmit
 
no lldp receive
 
no cdp enable
 
service-policy output VSL-Queuing-Policy

 ◆ 出力されるメッセージ


 WARNING: Interface TenGigabitEthernet1/1 placed in restricted config mode. All extraneous configs removed!
 WARNING: Interface TenGigabitEthernet1/2 placed in restricted config mode. All extraneous configs removed!



 04. Virtual Switch Modeへのコンバート
 Conversion to virtual switch mode requires a restart for both switches. After the reboot, commands that specify
 interfaces with module/port now include the switch number. example : a port on a switching module is specified by
 switch/module/port. Prior to the restart, the VSS converts the startup configuration to use the switch/module/port
 convention. A backup copy of the startup configuration file is saved in bootflash. This file is assigned a default name,
 but you are also prompted to override the default name if you want to change it.

 ◆ SW1 の設定
 SW1# switch convert mode virtual


 
◆ SW2 の設定
 SW2# switch convert mode virtual

 ・ SW1 ⇒ SW2の順番でswitch convert mode virtualコマンドを実行。実行後の再起動中にVSLリンクのケーブルを接続。
 ・ switch convert mode virtual コマンド実行後にスイッチが再起動する。再起動後にVSL Initializationが発生しVSSが形成。
 ・ デフォルトでは、VSL接続されたスイッチのうち、最初に起動完了したスイッチがActiveスイッチとしてアサインされる。
 ・ Active機にStandby機のコンフィグレーションが自動ダウンロードされる。
 ・ VSSの形成後は、Standby側のスイッチコンソールはDisable状態になる。
 ・ VSSの形成後は、mac-address use-virtual が自動的に設定されて、物理シャーシではなくVSS用のMACアドレスが使用される。
 ・ VSL Port-Channelメンバーに物理ポートが構成されると自動的にQoSコンフィグレーション(グローバルとI/F)が適用される。



 VSSスイッチとなった機器で設定保存すると以下のようなメッセージが出力されるようになります。

 
◆ 設定保存 ( write memory ) 実行時に出力されるログ
 %C4K_REDUNDANCY-5-CONFIGSYNC: The private-config has been successfully synchronized to the standby supervisor
 %C4K_REDUNDANCY-5-CONFIGSYNC: The startup-config has been successfully synchronized to the standby supervisor


 ◆ Catalyst4500-X VSS - Stand-aloneモードへのコンバート

 VSS状態であるVirtual Switchモードから、単体状態のStand-aloneモードへ変更するためには、以下の
 switch convert mode stand-aloneコマンドを実行します。コマンドを実行すると自動的に再起動が発生。
 再起動後はVSSの設定が削除されて起動します。なお、コンバートの実行は2台とも行う必要があります。


 
SW1-VSS# switch convert mode stand-alone

 
This command will convert all interface names
 to naming convention "interface-type slot/port",
 save the running config to startup-config and
 reload the switch.
 VSL, if up, will go down during the conversion and
 may cause dual-active condition for a brief period.
 Do you want to proceed? [yes/no]:
yes


 当然ながら、switch convert mode virtualコマンドやswitch convert mode stand-aloneコマンドは
 運用中には実行してはいけないコマンドです。これは構築時や検証時において実行するコマンドとなります。



 ◆ 付録 : Cisco SFP-10G-SRに光ファイバーを接続していない時に出力されるメッセージ

 Catalyst4500-Xにおいて、例えばCisco SFP-10G-SRを接続している状態で、そのSFPに光ファイバーの
 ケーブルを接続していないと以下のようなメッセージが出力される場合があります。しかし、ケーブル接続
 すれば本メッセージは出力されなくなります。信号を上手く受信できていないというメッセージだからです。
 ケーブル接続しても出力される場合、そのケーブルか、対向機器のSFP+に問題がある可能性があります。

 
8472-5-THRESHOLD_VIOLATION: Te1/1: Rx power low alarm; Operating value: -40.0 dBm, Threshold value: -13.9 dBm.
 8472-5-THRESHOLD_VIOLATION: Te1/2: Rx power low alarm; Operating value: -40.0 dBm, Threshold value: -13.9 dBm.



VSS Config - Catalyst4500-X

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.