Catalyst 4500X - VSS - config 2



 ◆ Catalyst4500-X VSSの設定 - スイッチプライオリティの設定

 
◇ スイッチプライオリティの設定
 If you boot both switches simultaneously, the switch configured as Switch 1 boots as VSS active
 and the one with Switch 2 boots as VSS standby. If priority is configured, the higher priority switch becomes active.

 If you boot only one switch, the VSL ports remain inactive, and the switch boots as VSS active.
 When you subsequently boot the other switch, the VSL links become active, and the new switch boots
 as the VSS standby switch.
Because preemption is not supported, if a VSS active is already running,
 the peer switch would always receive the VSS standby role, even if its priority is higher than that of the active switch.

 Configures the priority for the switch. The switch with the higher priority assumes the VSS active role.
 The range is 1 (lowest priority) to 255 (highest priority); the default is 100.

 ◆ SW1 の設定(SW2はデフォルトの 100 とする)

 
SW1(config)# switch virtual domain 100
 SW1(config-vs-domain)# switch 1 priority 200



 ◆ Catalyst4500-X VSSの設定 - デュアルアクティブとは

 VSLに障害が発生した場合、Standby機ではActive機のシャーシ状態を判断できなくなります。その結果、
 Standby機ではActive機に障害が発生したと判断して、Standby機はActive機の役割を引き継ごうとします。
 元のActive機が動作可能な場合、両方のシャーシがActive状態になってしまいます・・。この状態のことを
 デュアルアクティブと言います。この状態では両シャーシで同じIPアドレス、SSHキー、STPブリッジIDが
 使用されるため、ネットワークが不安定な状態になる可能性があります。

 デュアルアクティブを回避するために、VSSでは以下の3つのプロトコルをサポートしています。
 @
Enhanced PAgP A IP Bidirectional Forwarding Detection (BFD) B VSLP dual-active fast-hello

 Catalyst4500-Xでは@とBがサポートされています。両方に言えることはVSLリンクとは別のリンクを設け
 VSLリンクの障害発生時に、そのリンクを介してActive機とStandby機の状態を確認しているということです。

 @ Enhanced PAgPの実装
 ePAgPを使用する場合、MECリンクを介してPAgPメッセージをやり取りを行う必要があるため、PAgP
 対応の隣接スイッチが必要となり、その隣接スイッチとPAgPによるEtherChannel接続が必要となります。


   



 A VSLP dual-active fast-hello
 VSLP dual-active fast-helloを使用する場合は、Active機とStandby機を直結するリンクを別途設けて、
 そのバックアップリンクを介して特別なhelloメッセージのやりとりをして状態監視を行います。ePAgPに
 比べて高速でありシンプルな実装であることが利点。また、ePAgPを使用できないネットワーク構成等で
 実装させます。例えば、スタック構成のCatalystスイッチとVSS構成のC4500-XとがEtherChannelを使用
 する場合、StackスイッチではPAgPを使用できないため、このVSLP dual-active fast-helloの実装が必須。


   



 ◆ Catalyst4500-X VSSの設定 - デュアルアクティブの設定

 ◇ Dual-Active Detectionの設定 - ePAgP
 If enhanced PAgP is running on the MECs between the VSS and its access switches, the VSS can use
 enhanced PAgP messaging to detect a dual-active scenario.By default, PAgP dual-active detection is enabled.
 However, the enhanced messages are only sent on port channels with trust mode enabled
. You must configure
 trust mode on the port channels that will detect PAgP dual-active detection. By default, trust mode is disabled.

 ◆ VSSを形成したスイッチ - ePAgPの設定

 C4500-VSS(config)# interface TenGigabitEthernet 1/1/15
 C4500-VSS(config-if)# switchport mode trunk
 C4500-VSS(config-if)# channel-group 11 mode desirable

 C4500-VSS(config)# interface TenGigabitEthernet 2/1/15
 
C4500-VSS(config-if)# switchport mode trunk
 C4500-VSS(config-if)# channel-group 11 mode desirable

 C4500-VSS(config)# interface port-channel 11
 C4500-VSS(config-if)# shutdown

 
C4500-VSS(config)# switch virtual domain 100
 C4500-VSS(config-vs-domain)# dual-active detection pagp
 C4500-VSS(config-vs-domain)# dual-active detection pagp trust channel-group 11

 C4500-VSS(config)# interface port-channel 11
 C4500-VSS(config-if)# no shutdown


 If PAgP dual-active detection is enabled, you must place the port channel in administrative down state before changing
 the trust mode. Use the
shutdown command in interface configuration mode for the port channel. Remember to use the
 no shutdown command to reactivate the port channels when you are finished configuring trust mode on the port channel.


 ◇ Dual-Active Detectionの設定 - Fast-Hello
 ・ You can configure a maximum of four I/Fs on each chassis to connect with the other chassis in dual-active I/F pairs.
 ・ Each interface must be directly connected to the other chassis and must not be a VSL link.
 ・ Each interface must be a physical port. Logical ports such as an SVI are not supported.
 ・ Configuring fast hello dual-active mode will automatically remove all existing configuration from the interface
   and will restrict the interface to fast hello dual-active configuration commands.
 ・ Unidirectional link detection (UDLD) will be disabled on fast hello dual-active interface pairs.

 ◆ VSSを形成したスイッチ - Fast-Helloの設定

 C4500-VSS(config)# switch virtual domain 100
 C4500-VSS(config-if)# dual-active detection fast-hello

 C4500-VSS(config)# interface TenGigabitEthernet 1/1/10
 
C4500-VSS(config-if)# dual-active fast-hello

 C4500-VSS(config)# interface TenGigabitEthernet 2/1/10
 
C4500-VSS(config-if)# dual-active fast-hello

 【 設定時に出力されるメッセージ 】
 %SPANTREE-6-PORTDEL_ALL_VLANS: TenGigabitEthernet1/1/10 deleted from all Vlans
 %SPANTREE-6-PORTDEL_ALL_VLANS: STANDBY:TenGigabitEthernet1/1/10 deleted from all Vlans

 【 自動的に追加されるコンフィグ 】
 switchport mode access
 switchport nonegotiate

 【 Dual-active fast-hello インターフェース接続時に出力されるメッセージ 】
 %C4K_IOSINTF-5-TRANSCEIVERINSERTED: Slot=1 Port=10: Transceiver has been inserted
 %FASTHELLO-5-FH_UP: Fast-Hello interface Te1/1/10 status changed to link up

 %FASTHELLO-5-FH_UP: Fast-Hello interface Te2/1/10 status changed to link up
 %FASTHELLO-5-FH_DUAL_ACTIVE_CAP: Fast-Hello interface Te1/1/10 became dual-active detection capable

 %FASTHELLO-5-FH_UP: STANDBY: Fast-Hello interface Te2/1/10 status changed to link up
 %FASTHELLO-5-FH_DUAL_ACTIVE_CAP: STANDBY: Fast-Hello interface Te2/1/10 became dual-active detection capable
 %FASTHELLO-5-FH_UP: STANDBY: Fast-Hello interface Te1/1/10 status changed to link up

 Catalyst4500Xでは、デュアルアクティブ回避の
 ために、上記で紹介した
ePAgPFast-hello
 対応しています。どちらを使用するのが推奨かは
 Ciscoのサイトに書かれていませんが、設計上や
 運用上の分かり易さという観点ではFast-helloが
 優れているかと思います。また、C4500-Xと接続
 するスイッチがスタック構成である場合、ePAgP
 を使用できないので、必然的にFast-helloが必要。

 ちなみに、これらの実装はチャネル接続された
 リンクが全断した場合に使用されるリンクである
 ので、二重障害発生時の問題回避のための実装。



VSS Config - Catalyst4500-X

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.