Catalyst 4500X - VSS - config sample 1



 ◆ Catalyst4500-X VSS設定例 その1


  


 ◆ boot時に使用するIOS-XEイメージの指定(SW1 と SW2 とで同じものを指定する)
 SW1(config)# boot system flash bootflash:/cat4500e-universalk9.SPA.03.05.00.E.152-1.E.bin
 SW2(config)# boot system flash bootflash:/cat4500e-universalk9.SPA.03.05.00.E.152-1.E.bin


 ◆ ドメインとプライオリティ設定

 
SW1(config)# switch virtual domain 100
 SW1(config-vs-domain)# switch 1
 SW1(config-vs-domain)# switch 1 priority 200


 
SW2(config)# switch virtual domain 100
 SW2(config-vs-domain)# switch 2


 ◆ VSLリンクの設定

 
SW1(config)# interface port-channel 1
 SW1(config-if)# switchport
 SW1(config-if)# switch virtual link 1
 SW1(config-if)# no shutdown

 SW1(config)# interface range TenGigabitEthernet 1/1 - 2
 SW1(config-if-range)# channel-group 1 mode on


 
SW2(config)# interface port-channel 2
 SW2(config-if)# switchport
 SW2(config-if)# switch virtual link 2
 SW2(config-if)# no shutdown

 SW2(config)# interface range TenGigabitEthernet 1/1 - 2
 SW2(config-if-range)# channel-group 2 mode on


 ◆ SW1とSW2のコンバート
 SW1# switch convert mode virtual
 SW2# switch convert mode virtual


 SW1 : Initializing as Virtual Switch ACTIVE processor
 SW2 : Initializing as Virtual Switch STANDBY processor

 以降、Standby機でのコンソール設定はできなくなる。管理ポートの設定もActive機の設定が踏襲される。

 SW1-standby>
 Standby console disabled.
 Valid commands are: exit, logout


 ◆ VSSを形成したスイッチ - ePAgPの設定 for MEC

 SW1-VSS(config)# interface TenGigabitEthernet 1/1/15
 
SW1-VSS(config-if)# switchport

 SW1-VSS(config-if)# switchport mode trunk
 SW1-VSS(config-if)# switchport trunk allowed vlan 10,20
 
SW1-VSS(config-if)# switchport nonegotiate
 SW1-VSS(config-if)# channel-group 11 mode desirable

 SW1-VSS(config)# interface TenGigabitEthernet 2/1/15
 SW1-VSS(config-if)# switchport
 
SW1-VSS(config-if)# switchport mode trunk
 SW1-VSS(config-if)# switchport trunk allowed vlan 10,20
 SW1-VSS(config-if)# switchport nonegotiate
 SW1-VSS(config-if)# channel-group 11 mode desirable

 SW1-VSS(config)# interface port-channel 11
 SW1-VSS(config-if)# shutdown


 SW1-VSS(config)# switch virtual domain 100
 SW1-VSS(config-vs-domain)# dual-active detection pagp
 SW1-VSS(config-vs-domain)# dual-active detection pagp trust channel-group 11

 SW1-VSS(config)# interface port-channel 11
 SW1-VSS(config-if)# no shutdown


 ◆ インターフェースVLANの作成

 SW1-VSS(config)# spannning-tree mode rapid-pvst

 SW1-VSS(config)# vlan 10
 SW1-VSS(config)# vlan 20

 
SW1-VSS(config)# ip routing

 SW1-VSS(config)# interface vlan 10
 SW1-VSS(config-if)# ip address 192.168.10.1 255.255.255.0
 SW1-VSS(config-if)# no shutdown

 
SW1-VSS(config)# interface vlan 20
 SW1-VSS(config-if)# ip address 192.168.20.1 255.255.255.0
 
SW1-VSS(config-if)# no shutdown


 ◆ C4500XとC3750Xを接続した時に出力されるメッセージ


 %C4K_IOSINTF-5-TRANSCEIVERINSERTED: Slot=1 Port=15: Transceiver has been inserted
 %EC-5-BUNDLE: Interface TenGigabitEthernet1/1/15 joined port-channel Port-channel11
 %EC-5-BUNDLE: STANDBY:Interface TenGigabitEthernet1/1/15 joined port-channel Port-channel11
 %C4K_IOSINTF-5-TRANSCEIVERINSERTED: Slot=11 Port=15: Transceiver has been inserted

 CDP-EV: RCVD CDP packet on TenGigabitEthernet1/1/15 with len
 CDP Packet Process DONE

 %EC-5-BUNDLE: Interface TenGigabitEthernet2/1/15 joined port-channel Port-channel11
 %EC-5-BUNDLE: STANDBY:Interface TenGigabitEthernet2/1/15 joined port-channel Port-channel11




 以下のコンフィグレーションはCatalyst3750X
 側のコンフィグとなります。10Gのモジュールで
 C3KX-NM-10G、またはC3KX-SM-10Gを使用
 した場合の設定例です。

 NetFlowを使用する要件がなければコスト的に
 C3KX-NM-10Gを使用することをお勧めします。



 interface TenGigabitEthernet1/1/1
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 10,20
  switchport mode trunk
  switchport nonegotiate
  channel-group 1 mode desirable

 interface TenGigabitEthernet1/1/2
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 10,20
  switchport mode trunk
  switchport nonegotiate
  channel-group 1 mode desirable




VSS Config - Catalyst4500-X

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.