Cisco ASA - Setup / ASDM



 ◆ Cisco ASAの入手

 Cisco ASAは、ローエンドのASA 5505の機種である場合は、現在5万円前後で手に入れることができます。
 学習用として役立つだけでなくインターネット接続(Bフレッツ)ルータとしても使用できるのでお勧めです。



 ◆ コンソール接続

 Cisco ASAにコンソール接続するためには、Ciscoルータと同じようにシリアルポートに以下の設定をします。


              



 ◆ 初期化と再起動

 工場出荷時のデフォルト状態では不要な設定が入っているため、以下手順で初期化と再起動をしましょう。


     



 再起動が完了した後、Pre-configure Firewall now through interactive prompts [yes]? と表示されます。
 対話型セットアップを行いたい場合は yes と入力します。no と入力して基本設定する方がいいです。そして
 no と入力しコンフィグレーションモードへ移行すると機種やバージョンにより以下メッセージが出力します。
 Anonymous error reporting をイネーブルにしたい場合はYですが各自で判断します。当方はNと入力します。


     

 ※ ちなみに (config)# configure factory-default により初期化ではなく、工場出荷時の状態に戻せます。


 ◆ ASDMへアクセスするための設定 ( ASA5505の設定例 )

 Cisco製品のGUIツールのなかでASAのGUIツールのASDM (Adaptive Security Device Manager)は、非常に
 性能が良く使いやすいソフトウェアです。ネットワーク管理者はCLIよりもこのGUIを使用して管理/設定する
 ことが多い。そのASDMへの利用するための設定方法とアクセス方法を以下に紹介します。コマンドの詳細に
 ついては、次ページ移行で詳細に解説。先ず、管理アクセスするためのインターフェースとパスワードを設定。

 
◆ 設定例 : interface vlan 1 に 192.168.1.254 の IPアドレスを割り当て、物理インターフェースに E0/1 へVlan1を適用

 (config)# interface Vlan1
 
(config-if)# nameif inside
 
(config-if)# security-level 100
 
(config-if)# ip address 192.168.1.254 255.255.255.0

 
(config)# interface Ethernet 0/1
 
(config-if)# switchport mode access
 
(config-if)# switchport access vlan 1
 
(config-if)# no shutdown


 ※ 「switchport mode access」「switchport access vlan1」「no shutdown」は running-configでは表示されません。


 
◆ 設定例 : enable password に “ cisco ” と設定
 (config)# enable password cisco


 ASDMでのアクセスにはHTTPSサーバを有効化し、ASAのHTTPSサーバにアクセスする許可対象を設定。

 
◆ 設定例 : HTTPSサーバイネーブルにし、192.168.1.0/24 の送信元アドレスをASAにアクセスする許可対象として指定

 (config)#
http server enable 443
 (config)# http 192.168.1.0 255.255.255.0 inside




 ◆ ASDMへアクセス

 上記の設定通り、ブラウザのURLで https://192.168.1.254/ と入力して、ASAへアクセスします。

 



 次に、ブラウザでは以下の画面が表示されるので、「Install ASDM Launcher」を選択して
 クライアントPCにASDMをインストールしましょう。

 



 次に、ここでは先ほど設定したパスワード(cisco)だけを入力し、OKを選択します。

        



 次に、「保存」を選択して、デスクトップなど適当な場所に保存しましょう。

 



 次に、ダウンロードした「dm-launcher.msi」をダブルクリックして、以下のとおり「実行」を選択します。
 その後は「Next」や「OK」を選択していくだけでセットアップウィザードは完了します。

        



 最後に、以下の画面が表示されるのでASAのIPアドレスと設定したパスワードを入力して「OK」を選択する。

     


   



 そうするとASDMが起動します。このASDMでほぼ全てのコンフィグレーションとモニタリングが可能です。

 


 次回以降、ASAにASDMを使用してアクセスする場合、デスクトップのCisco ASDM-IDM Launcherを選択して起動させるだけです。
 ASDMのインストールや実行が上手くいかない場合、Windowsファイアウォールやウィルスソフト等を無効にして再試行しましょう。



Cisco ASA - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.