Cisco ASA - nameif / IP address / Interface



 ◆ ASA - インターフェースの名前付け(nameif)

 ASAではL3インターフェースに名前を設定する。最大48文字のテキストの文字列で大文字小文字は区別しない。
 一般的には内部ネットワークは
inside、外部ネットワークはoutside、DMZはdmzと設定することが多いです。
 名前をinsideにするとセキュリティレベルは100、outsideとするセキュリティレベルが0に自動で設定されます。

 ◆ インターフェース名の設定 - 最大48文字のテキストの文字列(大文字小文字は区別されない)
 (config-if)#
nameif name

 
◆ 設定例 : インターフェース Ethernet0/0 の名前を「inside」とする設定

 (config)#
interface Ethernet0/0
 (config-if)# nameif inside




 ◆ ASA - インターフェースの設定 - ルーテッドポートの設定

 ローエンド機種を除いてASAの物理ポートはルーテッドポートとして使用することが一般的です。IPアドレスの
 設定自体はCiscoルータと同じ設定内容となりますが「nameif」や「security-level」の設定が必要となります。

 
◆ 設定例 : インターフェース Ethernet0/0 の名前を「inside」セキュリティレベルを「100」IPを「10.1.1.254/24」とする

 (config)#
interface Ethernet0/0
 (config-if)# nameif inside
 (config-if)# security-level 100
 (config-if)# ip address 10.1.1.254 255.255.255.0

 (config-if)# no shutdown



 ◆ ASA - インターフェースの設定 - スイッチポートの設定(ASA5505など)

 
◆ VLANインターフェースの設定
 (config)#
interface vlan number

 
◆ IPアドレスの設定
 (config-if)#
ip address ip-address subnetmask

 
◆ インターフェース名の設定
 (config-if)#
nameif name

 
◆ セキュリティレベルの設定
 (config-if)#
security-level number

 
◆ 設定例 : インターフェースVLAN100 を追加するための設定

 (config)#
interface vlan 100
 (config-if)# ip address 192.168.100.254 255.255.255.0



 ◆ アクセスVLAN割り当ての設定
 (config-if)#
switchport access vlan number

 
◆ speed の設定 ( オプション )
 (config-if)#
speed [ auto | 10 | 100 ]

 
◆ duplex の設定 ( オプション )
 (config-if)#
duplex [ auto | half | full ]

 
◆ インターフェースのイネーブルの設定
 (config-if)#
no shutdown

 
◆ 設定例 : インターフェース Ethernet0/0 に「VLAN100」を割り当て、speed/duplexを「100/Full」固定とするための設定

 (config)#
interface Ethernet 0/0
 (config-if)# switchport access vlan 100
 (config-if)# speed 100
 (config-if)# duplex full
 (config-if)# no shutdown


 
◆ トランクポートに割り当てるVLANの設定
 (config-if)#
switchport trunk allowed vlan vlan-range

 
◆ トランクポートへのネイティブVLANの設定
 (config-if)#
switchport trunk native vlan vlan-id

 
◆ ポートをトランクポートにする設定( ASAのポートはデフォルトでアクセスポート )
 (config-if)#
switchport mode trunk



 ◆ ルーティングの設定

 
◆ スタティックルートの設定
 (config)#
route if-name dest-ip mask gateway-ip [ distance ]

 
◆ 設定例 : “outside”インターフェース先に存在する宛先ネットワーク ( 10.1.1.0/24 ) のネクストホップを172.16.1.1と指定
 (config)# route outside 10.1.1.0 255.255.255.0 172.16.1.1


 ◆ デフォルトルートの設定
 (config)#
route 0.0.0.0 0.0.0.0 gateway-ip [ distance | tunneled ]
 ⇒ tunneled オプションを指定すると、ASAに着信するトンネルからの全てのトラフィックは、最終的にこのルートに送信される。

 
◆ 設定例 : “outside”インターフェース先へ、デフォルトルートのネクストホップを172.16.1.1と指定

 (config)# route outside 0.0.0.0 0.0.0.0 172.16.1.1



Cisco ASA - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.