RIP - Cisco Config 3



 ◆ RIP - 手動経路集約の有効化

 RIPv2では、手動経路集約をサポートしており、インターフェース上で任意の経路集約が可能です。

 ◆ 手動経路集約の設定
 (config)#
interface interface-id
 (config-if)#
ip summary-address rip network subnetmask

 ◆ 設定例 : 172.16.0.0/24 〜 172.16.3.0/24 のネットワークを Gi 0/0上で「 172.16.0.0/22」に手動経路集約

 
Cisco(config)# interface GigabitEthernet 0/0
 Cisco(config-if)#ip summary-address rip 172.16.0.0 255.255.252.0


 ただし、RIPv2の場合はクラスフル境界の左側に向けたCIDRの集約をサポートしていませんので、
 例えば 172.16.0.0/24 〜 172.31.0.0/24 のネットワークを「172.16.0.0/12」と集約できません。



 ◆ RIP - ホップ数の制御

 RIPv2ではoffset-listコマンドを使用することで、
特定の宛先ネットワークに対してホップ数を加算させる
 ことができます。これにより、特定の宛先ネットワークに対して意図した経路で通信させることができます。

 ◆ offset-list の設定
 (config)#
access-list acl-number permit network wildcard

 (config)#
router rip
 (config-router)# offset-list acl-number in | out hop-count interface

 
◆ 設定例 : R1のGi0/0のインターフェースで受信した「172.16.1.0/24」の現在のホップ数に対して、ホップ数を「3」加算

 
R1(config)# access-list 1 permit 172.16.1.0 0.0.0.255

 R1(config)# router rip
 R1(config-router)#offset-list 1 in 3 GigabitEthernet0/0


 上記の設定例では経路を受信した際にホップ数を加算していますが、下記の設定例では経路を発信した際に
 ホップ数を加算しています。従って、R1のルータのルーティングテーブルでは、同じ結果が得られます。

 ◆ 設定例 : R2のGi0/1のインターフェースで発信する「172.16.1.0/24」の現在のホップ数に対して、ホップ数を「3」加算

 
R2(config)# access-list 1 permit 172.16.1.0 0.0.0.255

 R2(config)# router rip
 R2(config-router)#offset-list 1 out 3 GigabitEthernet0/1



 ※ 以降で紹介するRIPv2のコマンドは一般的な設定ではありませんので、あくまで参考情報として下さい。


 ◆ RIP - タイマーの設定

 RIPv2の各タイマー( update、invalid、holddown、flush )の値を変更することができます。

 
◆ RIPv2のタイマー設定
 (config)#
router rip
 (config-router)#
timers basic update invalid holddown flush



 ◆ RIP - トリガーアップデートの設定

 RIPv2はデフォルトで30秒に一回ルーティングアップデートを送出しますが、Serialインターフェースに
 限り、この定期的なアップデートを止めて、変更があった時のみアップデートを行うように設定できます。

 
◆ RIPv2のトリガーアップデートの設定
 (config)#
interface interface-id
 (config-router)#
ip rip triggered



 ◆ RIP - ソースIPアドレスの検証の無効化

 RIPv2は、デフォルトで受信するルーティングアップデートの送信元IPアドレスを検証します。その結果、
 送信元アドレスが無効である場合には、アップデートを破棄します。通常、この機能を無効にすることは
 推奨されませんが、送信元IPアドレスをチェックしないようにするためには以下のコマンドを設定します。

 
◆ RIPv2のソースIPアドレスの検証の無効化
 (config)#
router rip
 (config-router)#
no validate-update-source



 ◆ RIP - RIPパケットの送出間隔の調整

 RIPv2のルーティングアップデートは、実は複数のRIPパケットから構成されています。デフォルトでは
 これらの複数のRIPパケットは連続して遅延なく送出されますが、ルーティングアップデートを受信する
 対向側のデバイス(RIPルータ)の処理能力が低い場合、そのデバイスの処理能力にあわせられるように、
 RIPパケットの送出間隔を遅延(8 〜 50ミリ秒)を追加し調整することが可能です。※ レガシーな機能。

 
◆ RIPv2パケットの送出間隔の調整
 (config)#
router rip
 (config-router)#
out-delay delay



 ◆ RIP - ネイバー設定

 RIPv2 のマルチキャストアップデートによる経路情報の交換ではなくて、ネイバーを指定したユニキャスト
 アップデートで経路情報を交換できます。neighbor指定をする代わりに該当I/Fではpassive-interfaceを適用。

 
◆ RIPv2ネイバーの設定
 (config)#
router rip
 (config-router)#
neighbor ip-address
 (config-router)#
passive-interface interface



 ◆ RIP - ネイバー認証

 ネイバー認証を行うことで、認証が成功したRIP機器とのみルーティング情報をやりとりすることになる
 ことから、不正なルート更新によってルーティング テーブルの内容を壊されることを防ぐことができます。

 
◆ RIPv2ネイバー認証の設定
 (config)#
key chain name
 (config-keychain)#
key key-id
 (config-keychain-key)# key-string password

 (config)#
interface interface-id
 (config-if)#
ip rip authentication mode [ md5 | text ]
 (config-if)#
ip rip authentication key-chain name



 ◆ RIP - アクセスリストによる制御

 ある「特定のRIPルータからしか」RIPv2のマルチキャストアップデートによる経路情報を受け取らない、
 という制御をするためにはACLで制御します。例えば「192.168.0.1」からのRIPv2ルータからしかRIPv2
 のアップデート情報を受信したくない場合は以下の設定を行います。最後にその他のトラフィックを許可。

 (config)# access-list 101 permit udp host 192.168.0.1 any eq rip
 (config)#
access-list 101 deny udp any any eq rip
 (config)#
access-list 101 permit ip any any

 (config)# interface GigabitEthernet0/1
 (config-if)# ip address 192.168.0.254 255.255.255.0
 (config-if)# ip access-group 101 in



ディスタンスベクタ型ルーティング - RIP

ネットワークエンジニアとして

Copyright (C) 2002-2021 ネットワークエンジニアとして All Rights Reserved.