EIGRP - default route



 ◆ EIGRP - デフォルトルートの配布

 EIGRPネットワークで、デフォルトルートを配布する方法は、大きく以下の4つの方法があります。

 @ スタティックのデフォルトルートを
redistributeコマンドでルート再配布させる
 A スタティックのデフォルトルートを
network 0.0.0.0コマンドを定義して通知させる
 B 
ip default-networkコマンドを使用して、デフォルトルートを通知させる
 C 
ip summary-address eigrpコマンドを使用して、デフォルトルートを通知させる

 実際の企業ネットワークで使用されている主な手法は@です。それでは、各設定を見ていきましょう。



 ◆ EIGRP - デフォルトルートの配布 その1

 EIGRPネットワークにおいて、スタティックのデフォルトルートをredistributeコマンドで再配布させる
 設定は以下となります。EIGRPにおけるデフォルトルートの通知といえば、一般的にこの設定で行います。

 
◆ EIGRPのデフォルトルートの配布 その1
 (config)#
ip route 0.0.0.0 0.0.0.0 interface | next-hop
 (config)#
router eigrp as-number
 (config-router)# redistribute static

 ◆ EIGRPのデフォルトルートの配布 設定例1


 Cisco(config) # ip route 0.0.0.0 0.0.0.0 172.16.1.254

 Cisco(config) # router eigrp 1
 Cisco(config-router) # redistribute static



 ◆ EIGRP - デフォルトルートの配布 その2

 EIGRPネットワークにおいて、スタティックのデフォルトルートをnetwork 0.0.0.0コマンドで通知させる
 設定
は以下となります。一般的にこのような設定は行いません。なお、この方法でデフォルトルートを設定
 する時は、ネクストホップにインターフェースを指定する必要があります。

 
◆ EIGRPのデフォルトルートの配布 その2
 (config)#
ip route 0.0.0.0 0.0.0.0 interface-id
 (config)#
router eigrp as-number
 (config-router)# network 0.0.0.0

 ◆ EIGRPのデフォルトルートの配布 設定例2


 Cisco(config) # ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

 Cisco(config) # router eigrp 1
 Cisco(config-router) # network 0.0.0.0




 ◆ EIGRP - デフォルトルートの配布 その3

 この通知方法はデフォルトルートの配布というよりも、ラストリゾートゲートウェイとなるデフォルト
 ネットワークの生成と言えます。設定コマンドは
ip default-networkであり、コマンドのネットワーク
 指定は
クラスフルに指定する必要があります。また、デフォルトネットワークを生成するEIGRPルータが
 そのネットワークに直接接続されているなど、デフォルトネットワークに到達性がある必要があります。

 ◆ EIGRPのデフォルトルートの配布 その3
 (config)#
router eigrp as-number
 (config-router)#
network address wildcard-mask
 (config)#
ip default-network classfull-address

 ◆ EIGRPのデフォルトルートの配布 設定例3

 Cisco(config) # router eigrp 1
 Cisco(config-router) # network 192.168.1.0 0.0.0.255

 Cisco(config) # ip default-network 192.168.1.0




 ◆ EIGRP - デフォルトルートの配布 その4

 ip summary-address eigrpコマンドはデフォルトルートの配布のためではなく、本来は特定サブネットを
 集約した集約ルートを通知するために使用しますが、0.0.0.0を指定することでデフォルトルートを生成して
 ネイバーに配布することも可能です。ただしこの設定によりデフォルトルート以外は通知されなくなります。

 ◆ EIGRPのデフォルトルートの配布 その4
 (config)#
interface interface-id
 (config-if)#
ip summary-address eigrp as-number
0.0.0.0 0.0.0.0

 ◆ EIGRPのデフォルトルートの配布 設定例4

 Cisco(config) # interface GigabitEthernet0/0

 Cisco(config-if) # ip summary-address eigrp 1 0.0.0.0 0.0.0.0


 また、この集約ルートのAD値は「 5 」であることから、集約ルートを生成したルータで再配布された
 デフォルトルート( AD値 170 )を持っていた場合、集約ルートを生成時に作成されるEIGRPのNull
 ルート置き換えられてしまいます。デフォルトルートの集約ルートの設定前と設定後を見てみましょう。

 
◆ I/Fで集約ルートを設定する前のルータのshow ip routeの抜粋
 
D*EX 0.0.0.0/0 [170/307200] via 10.1.2.1, 00:02:06, GigabitEthernet0/0

 
◆ I/Fで集約ルートを設定した後のルータのshow ip routeの抜粋
 
D* 0.0.0.0/0 is a summary, 00:17:42, Null0

 集約ルートを生成したルータで、別のルータから再配布されているデフォルトルートを消さないように
 するためには、以下の設定の通り集約ルート生成時に、AD値を170よりも大きくすればOKとなります。


 Cisco(config) # interface GigabitEthernet0/0

 Cisco(config-if) # ip summary-address eigrp 1 0.0.0.0 0.0.0.0 200




EIGRP - コンフィグ設定:応用

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.