HSRP - standby ip / priority / preempt



 ◆ HSRP - Ciscoコンフィグ設定

 以降で紹介するHSRPの設定は、HSRPグループ内のすべてのルータで設定する必要があります。先ずは、
 HSRPを有効化するL3インターフェースを指定して、HSRPグループ番号と仮想IPアドレスを設定します。
 L3インターフェースなので「L3スイッチのSVI」でも「ルーテッドポート」でも「ルータのI/F」でもOK。

 
◆ HSRPの有効化設定
 (config)# interface interface-id
 (config-if)#
standby group-number ip address

コマンド引数 説明
group-number

 デフォルトのHSRP version 1 の場合は「 0 〜 255 」の中から任意整数を指定。
 ※ HSRP version 2 の場合は「 0 〜 4095」の中から任意整数を指定。

address


 仮想IPアドレスの設定。例えば、PCなどが指定するデフォルトゲートウェイのIPアドレスとなる。
 設定例:インターフェースVLAN「10」、HSRPグループ番号「10」、仮想IPアドレス「192.168.10.254」


 (config)#
interface vlan 10
 (config-if)# standby 10 ip 192.168.10.254




 ◆ HSRPのプライオリティ設定
 (config-if)#
standby group-number priority priority

コマンド引数 説明
group-number

 デフォルトのHSRP version 1 の場合は「 0 〜 255 」の中から任意整数を指定。
 ※ HSRP version 2 の場合は「 0 〜 4095」の中から任意整数を指定。

priority


 HSRPのプライオリティ値を「1 〜 255」から指定。デフォルト値は「100」となる。HSRPグループ内で
 同じプライオリティ値である場合は、最も大きいIPアドレスが持つルータがアクティブルータとなる。
 設定例:HSRPグループ番号「10」においてプライオリティ値を「105」とする設定

 (config-if)# standby 10 priority 105



 HSRPのデフォルトでは、HSRPグループでアクティブルータが
すでに存在する場合、そのアクティブルータ
 よりも高いプライオリティを持つルータが
後から同じHSRPグループに参加しても、アクティブルータになる
 ことは出来ません。しかし、設定後や起動時の時差がある場合でも、プライオリティ値が高いデバイスが必ず
 アクティブルータとなるようにできる機能があって、その機能を
プリエンプト機能( preempt )と言います。

 ◆ HSRPのプリエンプト設定
 (config-if)#
standby group-number preempt

 preempt設定はその特性から
アクティブルータ側だけに設定すれば良いのですが、両方のルータに設定して
 おいても何も問題は発生しないので、両方に設定しておいて問題ありません。また、別途解説するHSRPの
 インターフェーストラッキング等ではアクティブルータとスタンバイルータの両方に設定が必要となります。



 ◆ SW1 - コンフィグ設定

 SW1(config) #
interface vlan 5
 SW1(config-if) # ip address 172.16.5.1 255.255.255.0
 SW1(config-if) # standby 5 ip 172.16.5.254
 SW1(config-if) # standby 5 priority 105
 SW1(config-if) # standby 5 preempt


 ◆ SW2 - コンフィグ設定

 SW2(config) #
interface vlan 5
 SW2(config-if) # ip address 172.16.5.2 255.255.255.0
 SW2(config-if) # standby 5 ip 172.16.5.254
 SW1(config-if) # standby 5 priority 100

 ※ SW2のコンフィグの「standby 5 priority 100」の「100」はデフォルト値なのでこの1行はコンフィグ上表示されません。

 設定完了後は
show standby brief コマンドで、全てのHSRPグループの状態が一覧で確認してみましょう。



 ◆ HSRP - デフォルト値

機能 デフォルト値
 HSRPバージョン  verison 1
 HSRPグループ  未設定
 スタンバイグループ番号  0
 スタンバイMACアドレス  0000.0c07.acXX
 スタンバイプライオリティ  100
 スタンバイ遅延  0(遅延なし)
 インターフェイス プライオリティの追跡  10
 Helloタイマー  3
 Holdタイマー  10



HSRPとは HSRP( Hello/Holdタイマー、preempt delay、version、認証 )設定

ネットワークエンジニアとして

Copyright (C) 2002-2020 ネットワークエンジニアとして All Rights Reserved.