IPv6 - OSPFv3 Address Family



 ◆ OSPFv3 - アドレスファミリ

 OSPFv3アドレスファミリでは、
IPv4とIPv6を1つのOSPFv3プロセスでサポートすることができます。
 従来のOSPFv3の設定では、IPv4の場合はOSPFv2を起動させて、IPv6の場合はOSPFv3を起動させる
 必要があり、個別にプロセスを起動させる必要がありましたが、OSPFv3アドレスファミリの設定では、
 IPv4とIPv6を1つのOSPFv3プロセスでサポートできるので、IPv4とIPv6のルート情報は
単一のリンク
 ステートデータベースに保持
することができます。デュアルスタック環境でとても役立つ設定手法です。

 
The OSPFv3 address families feature is supported as of Cisco IOS Release 15.1(3)S and Cisco IOS Release 15.2(1)T.


   


 router ospfv3 コマンドでは、1つのOSPFプロセスで定義することから、IPv4とIPv6で共通で使用する設定は
 1つのプロセスの中で設定(例えば上図におけるルータIDなど)します。一方、IPv4、IPv6に個別に設定したい
 パラメータは、address-familyコマンド配下に設定します。なお、OSPFv3ではnetworkコマンドを使用せずに
 インターフェース上でルーティングプロセスを有効にします。


 ◆ OSPFv3 - 基本設定

 OSPFv3のルーティングプロトコルのトラフィックはIPv6により伝送されます。そのため、IPv4ネットワークの
 ルート情報もIPv6パケットにカプセル化されて送信されます。従って、router ospfv3コマンドで、IPv4だけを
 使用する場合でも先ず以下の「 ipv6 unicast-routing 」を有効化させる必要があります。

 ◆ IPv6ルーティングの有効化
 (config)#
ipv6 unicast-routing


 次に、OSPFv3プロセスを起動させる設定をします。プロセス番号はローカルでのみ使用する番号となります。

 ◆ OSPFv3プロセスの起動
 (config)#
router ospfv3 proccess-id
 (config-router)#


 次に、OSPFのルーティングプロセスを有効化させるためにaddress-familyの設定をします。

 
◆ address-familyの設定
 (config-router)# address-family [ ipv4 | ipv6 ] unicast


 次に、ルータIDの設定をします。OSPFv3プロセスで共通の値を使用する場合、つまりaddress-family ipv4でも
 address-family ipv6でも同じ値を使用したい場合、router ospfv3コマンド配下で設定をして、address-family
 ごとに個別に設定をします。

 ◆ ルータIDの設定 - OSPFv3プロセスで共通の値を使用する場合
 (config)#
router ospfv3 proccess-id
 (config-router)# router-id router-id

 
◆ ルータIDの設定 - アドレスファミリごとに使用する場合
 (config)# router ospfv3 proccess-id
 (config-router)# address-family [ ipv4 | ipv6 ] unicast
 (config-router-af)#
router-id router-id


 最後に、インターフェース上でOSPFv3を有効化させます。

 ◆ インターフェース上でのOSPFv3の有効化
 (config-if)#
ospfv3 process-id address-family area
area-id

コマンド引数 説明
process-id

 OSPFv3のプロセスID

address-family

 OSPFv3を有効化させるaddress-familyの指定( ipv4 または ipv6 を指定 )

area-id

 インターフェースが所属するエリアIDの指定


 最低限の設定は以上となります。その他にもオプション設定は多数ありますが、アドレスファミリに対して
 
passive-interface(特定のI/Fからのアップデートの停止)、area 〜 range(ABRでのエリア間ルート集約)
 
summary-prefix(ASBRでの外部ルート集約)などの設定が主なコマンドとして挙げられます。



 ◆ OSPFv3アドレスファミリの設定例

 OSPFv3アドレスファミリの設定を利用して、IPv4とIPv6の経路情報をやり取りする設定例は次の通りです。


 R1(config) # ipv6 unicast-routing

 R1(config) #
router ospfv3 1
 R1(config-router) # router-id 1.1.1.1
 R1(config-router) # address-family ipv4 unicast
 R1(config-router-af) # exit-address-family
 R1(config-router) # address-family ipv6 unicast
 R1(config-router-af) # exit-address-family


 R1(config) #
interface GigabitEthernet0/0
 R1(config-if) # ip address 10.0.0.1 255.255.255.0
 R1(config-if) #
ipv6 address 2001:1:1:10::1/64
 R1(config-if) #
ipv6 address fe80::1 link-local
 R1(config-if) # ospfv3 1 ipv4 area 0
 R1(config-if) #
ospfv3 1 ipv6 area 0

 R1(config) # interface GigabitEthernet0/1
 R1(config-if) # ip address 172.16.1.254 255.255.255.0
 R1(config-if) # ipv6 address 2001:1:1:1::1/64
 R1(config-if) #
ipv6 address fe80::1 link-local
 R1(config-if) # ospfv3 1 ipv4 area 1
 R1(config-if) #
ospfv3 1 ipv6 area 1


 R2(config) # ipv6 unicast-routing

 R2(config) #
router ospfv3 1
 R2(config-router) # router-id 2.2.2.2
 R2(config-router) # address-family ipv4 unicast
 R2(config-router-af) # exit-address-family
 R2(config-router) # address-family ipv6 unicast
 R2(config-router-af) # exit-address-family


 R2(config) #
interface GigabitEthernet0/0
 R2(config-if) # ip address 10.0.0.2 255.255.255.0
 R2(config-if) # ipv6 address 2001:1:1:10::2/64
 R2(config-if) #
ipv6 address fe80::2 link-local
 R2(config-if) # ospfv3 1 ipv4 area 0
 R2(config-if) # ospfv3 1 ipv6 area 0

 R2(config) # interface GigabitEthernet0/1
 R2(config-if) # ip address 172.16.2.254 255.255.255.0
 R2(config-if) #
ipv6 address 2001:1:1:2::2/64
 R2(config-if) # ipv6 address fe80::2 link-local
 R2(config-if) # ospfv3 1 ipv4 area 2
 R2(config-if) # ospfv3 1 ipv6 area 2


 設定例では、IPv4ルートとIPv6ルートをルーティングさせていますが、OSPFv3アドレスファミリの設定では、
 IPv4ルートだけをルーティングさせることも可能です。冒頭で解説した通りIPv4ネットワークのルート情報は、
 IPv6パケットにカプセル化されて送信されるため、IPv4ルートだけをルーティングさせる場合でもコンフィグ
 として「
ipv6 unicast-routing」は必要である点と、I/FにIPv6アドレスを設定しない場合「ipv6 enable」の
 設定は必要となるため忘れないようにしましょう。なお、OSPFv3のステータス確認コマンドは以下の通りです。

OSPFv3のステータス確認 説明
 show ospfv3 neighbor

 OSPFv3ルータが認識しているネイバー情報をアドレスファミリごとに表示

 show ospfv3 interface brief

 OSPFv3が動作するインターフェース情報の一覧を表示

 show ospfv3 database

 OSPFv3のリンクステータス情報を表示

 show ip protocols  動作しているIPv4のルーティングプロトコルに関するパラメータを表示
 show ipv6 protocols  動作しているIPv6のルーティングプロトコルに関するパラメータを表示
 show ip route  IPv4のルーティングテーブルの情報を表示
 show ipv6 route  IPv6のルーティングテーブルの情報を表示



IPv6 とは

ネットワークエンジニアとして

Copyright (C) 2002-2020 ネットワークエンジニアとして All Rights Reserved.