MPLS-VPN - Sham Link Cisco Config



 ◆ MPLS-VPN:Sham Link Ciscoコンフィグ設定

 Sham Linkの設定はSham Linkを使用してOSPF情報を転送するエリアごとに
各PEルータで設定します。

 先ず、Sham Linkを形成するためのSham Link用のインターフェースをVRF上で設定します。32ビット
 マスクで設定して通常ループバックアドレスを使用します。

 
◆ Step1:Sham Link用のインターフェースの設定
 (config)#
interface loopback number
 (config-if)#
ip vrf forwarding name
 (config-if)# ip address ip-address mask


 次に、Sham Link用のインターフェースのアドレスはBGPでアドバタイズする必要があります。OSPFの
 情報を転送するための設定なのでOSPFでアドバタイズすると勘違いしそうですが、BGP側で通知します。

 ◆ Step2:Sham Link用のアドレスを通知するための設定
 (config)#
router bgp as-number
 (config-router)#
address family ipv4 vrf vrf-name
 (config-router-af)# network network-address mask mask


 最後に、Sham Linkとして利用する「送信元アドレス」「宛先アドレス」「エリア」をOSPFプロセス上で
 指定します。Sham Link上でのコスト値はここで設定します。

 ◆ Step3:Sham Linkの設定
 (config)#
router ospf process-id vrf vrf-name
 (config-router)#
area area-id sham-link source-address destination-address
cost number


 ◆ MPLS-VPN:Sham Link Ciscoコンフィグ設定例

 Sham Linkの設定は「各PE」で設定します。CEルータ側では、MPLS-VPNやSham Linkの設定を意識した
 設定は必要ありません。CE側は通常のOSPFルーティングのための設定をします。以下では、PE1側の設定
 だけを紹介します。この仮想リンクで接続する対向となるPE2ルータは対称的に設定すればOKとなります。

 ◆ PE1ルータの設定例

 PE1(config)#
interface loopback 1
 PE1(config-if)# ip vrf forwarding CUSTA
 PE1(config-if)# ip address 10.1.1.1 255.255.255.255

 PE1(config)# router bgp 65000
 PE1(config-router)# address family ipv4 vrf CUSTA
 PE1(config-router-af)# network 10.1.1.1 mask 255.255.255.255
 PE1(config-router-af)# redistribute ospf 11 vrf CUSTA match internal external
 
PE1(config-router-af)# exit-address-family

 
PE1(config)# router ospf 11 vrf CUSTA
 PE1(config-router) # redistribute bgp 65000 subnets
 
PE1(config-router) # area 10 sham-link 10.1.1.1 10.2.2.2


 ◆ PE2ルータの設定例

 PE2(config)#
interface loopback 1
 PE2(config-if)# ip vrf forwarding CUSTA
 PE2(config-if)# ip address 10.2.2.2 255.255.255.255

 PE2(config)# router bgp 65000
 PE2(config-router)# address family ipv4 vrf CUSTA
 PE2(config-router-af)# network 10.2.2.2 mask 255.255.255.255
 PE2(config-router-af)# redistribute ospf 11 vrf CUSTA match internal external
 PE2(config-router-af)# exit-address-family

 
PE2(config)# router ospf 11 vrf CUSTA
 PE2(config-router) # redistribute bgp 65000 subnets
 
PE2(config-router) # area 10 sham-link 10.2.2.2 10.1.1.1


 設定後、PEルータで
show ip ospf sham-links コマンドでステータスを確認します。特に以下の3点。

 ・ Sham Link OSPF_SL0 to address 10.2.2.2 is
up ⇒ up 状態であることを確認します。
 ・ Area 10 source address 10.1.1.1 ⇒ 対象エリアを確認します。
 ・ Adjacency State
FULLHello suppressed) ⇒ FULL状態であることを確認します。

 以上の3項目を確認することで、Area 10において Sham Link が正常に確立していることが分かります。
 また、CEルータで show ip route ospf で確認し、MPLS-VPN経由で受信した同一エリアのOSPFルートの
 コードも intra area「O」であることを確認しましょう。



MPLSとは

ネットワークエンジニアとして

Copyright (C) 2002-2020 ネットワークエンジニアとして All Rights Reserved.