Multicast PIM-SM - Static RP Config 1



 ◆ PIM-SMの設定

 CiscoルータでPIM-SMを動作させるためには、次の大きく3種類の設定が必要となります。

 ・ マルチキャストルーティングの有効化
 ・ マルチキャストパケットを転送させたい全てのインターフェースでのPIM-SMの有効化
 ・ RPアドレスの指定

 RPアドレスの指定方法には、スタティックRP、Auto-RP、BSRの大きく3つの方法があります。本記事では
 スタティックRPの設定方法について解説します。



 ◆ PIM-SMの設定 - スタティックRP

 PIM-SMにおいてスタティックRPを設定するためのコマンドは以下の通りです。

 ◆ マルチキャストルーティングの有効化( Catalystスイッチの場合、機種により ip multicast-routing distributed と設定 )
 (config)# ip multicast-routing

 
◆ マルチキャストパケットを転送させたいインターフェースでPIM-SMを有効化
 (config)# interface interface-id
 (config-if)#
ip pim sparse-mode

 
◆ RPアドレスをスタティックに指定
 (config)#
ip pim rp-address ipaddress ACL [ override ]

コマンド引数 説明
ipaddress  RPのアドレス
ACL  マルチキャストグループを指定するための標準ACLの番号
override  ルータでAuto-RP、BSRなどの設定があっても、このコマンド設定のRPを優先させるキーワード

 ※ ACLを指定しない場合、全てのマルチキャストグループの共通のRPアドレスのコンフィグ設定となります。


 ◆ PIM-SMの設定 - スタティックRP - コンフィグ設定例

 それでは、下図におけるコンフィグ設定例を紹介します。


    



 R1(config)# ip multicast-routing

 R1(config)# interface GigabitEthernet0/0
 R1(config-if)# ip address 10.1.1.254 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface GigabitEthernet0/2
 R1(config-if)# ip address 192.168.2.1 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface GigabitEthernet0/3
 R1(config-if)# ip address 192.168.3.1 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# access-list 10 permit 239.1.1.5
 R1(config)# ip pim rp-address 2.2.2.2 10


 R2(config)# ip multicast-routing

 R2(config)# interface GigabitEthernet0/1
 R2(config-if)# ip address 192.168.2.2 255.255.255.0
 R2(config-if)# ip pim sparse-mode

 R2(config)# interface GigabitEthernet0/2
 R2(config-if)# ip address 192.168.4.2 255.255.255.0
 R2(config-if)# ip pim sparse-mode

 R2(config)# interface loopback0
 R2(config-if)# ip address 2.2.2.2 255.255.255.255

 R2(config)# access-list 10 permit 239.1.1.5
 R2(config)# ip pim rp-address 2.2.2.2 10


 R3(config)# ip multicast-routing

 R3(config)# interface GigabitEthernet0/0
 R3(config-if)# ip address 172.16.1.254 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# interface GigabitEthernet0/1
 R3(config-if)# ip address 192.168.3.3 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# interface GigabitEthernet0/2
 R3(config-if)# ip address 192.168.4.3 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# access-list 10 permit 239.1.1.5
 R3(config)# ip pim rp-address 2.2.2.2 10




マルチキャスト - Ciscoコンフィグ設定


ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.