Multicast PIM-SM - Auto-RP Config 1



 ◆ PIM-SMの設定 - Auto-RP

 PIM-SMにおいて、Auto-RPを設定するためには先ずマルチキャストルーティングを有効化します。

 ◆ マルチキャストルーティングの有効化
 (config)# ip multicast-routing


 インターフェースでSparse-Denseモード(ip pim sparse-dense-mode)を有効にする設定パターンか、
 インターフェースでSparseモード(ip pim sparse-mode)有効 + Auto RP Listener機能を有効にする
 設定パターンのどちらかを設定します。

 
◆ 設定パターン1:マルチキャストパケットを転送させたいインターフェースでPIM-SMを有効化(Sparse-Denseモードの設定)
 (config)#
interface interface-id
 (config-if)#
ip pim sparse-dense-mode

 
◆ 設定パターン2:マルチキャストパケットを転送させたいインターフェースでPIM-SMを有効化 + Auto RP Listener機能の設定
 (config)#
interface interface-id
 (config-if)#
ip pim sparse-mode

 (config)#
ip pim autorp listener


 Auto-RPを設定するためには「RP Candidateの設定」と「RP Mapping Agentの設定」が必要となります。

 
◆ RP Candidateの設定
 (config)#
ip pim send-rp-announce interface-id scope TTL [ group-list ACL ] [ interval seconds ]

コマンド引数 説明
interface-id  RPのアドレスにするインターフェースの指定
TTL  RP-AnnounceメッセージのTTL値の指定
ACL  マルチキャストグループを指定するための標準ACLの番号
seconds  RP-Announceメッセージを送信する間隔( デフォルト値は60秒 )

 ※ ACLを指定しない場合、全てのマルチキャストグループの共通のRPアドレスのコンフィグ設定となります。


 
◆ RP Mapping Agentの設定
 (config)#
ip pim send-rp-discovery scope TTL

コマンド引数 説明
TTL  RPディスカバリパケットのTTL値の指定(RPディスカバリパケットの到達範囲の制限)


 ◆ PIM-SMの設定 - Auto-RPの設定例

 それでは、下図におけるコンフィグ設定例を紹介します。


    



 R1(config)# ip multicast-routing

 R1(config)# interface GigabitEthernet0/0
 R1(config-if)# ip address 10.1.1.254 255.255.255.0
 R1(config-if)# ip pim sparse-dense-mode

 R1(config)# interface GigabitEthernet0/2
 R1(config-if)# ip address 192.168.2.1 255.255.255.0
 R1(config-if)# ip pim sparse-dense-mode

 R1(config)# interface GigabitEthernet0/3
 R1(config-if)# ip address 192.168.3.1 255.255.255.0
 R1(config-if)# ip pim sparse-dense-mode

 R1(config)# interface loopback0
 R1(config-if)# ip address 1.1.1.1 255.255.255.255
 R1(config-if)# ip pim sparse-dense-mode

 R1(config)# ip pim send-rp-discovery loopback0 scope 16


 R2(config)# ip multicast-routing

 R2(config)# interface GigabitEthernet0/1
 R2(config-if)# ip address 192.168.2.2 255.255.255.0
 R2(config-if)# ip pim sparse-dense-mode

 R2(config)# interface GigabitEthernet0/2
 R2(config-if)# ip address 192.168.4.2 255.255.255.0
 R2(config-if)# ip pim sparse-dense-mode

 
R2(config)# interface loopback0
 
R2(config-if)# ip address 2.2.2.2 255.255.255.255
 
R2(config-if)# ip pim sparse-dense-mode

 
R2(config)# access-list 1 permit 239.1.1.5

 R2(config)# ip pim send-rp-announce loopback0 scope 16 group-list 1


 R3(config)# ip multicast-routing

 R3(config)# interface GigabitEthernet0/0
 R3(config-if)# ip address 172.16.1.254 255.255.255.0
 R3(config-if)# ip pim sparse-dense-mode

 R3(config)# interface GigabitEthernet0/1
 R3(config-if)# ip address 192.168.3.3 255.255.255.0
 R3(config-if)# ip pim sparse-dense-mode

 R3(config)# interface GigabitEthernet0/2
 R3(config-if)# ip address 192.168.4.3 255.255.255.0
 R3(config-if)# ip pim sparse-dense-mode




マルチキャスト - Ciscoコンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.