Multicast PIM-SM - BSR Config 1



 ◆ PIM-SMの設定 - BSR

 PIM-SMにおいて、BSRを設定するためには先ずマルチキャストルーティングを有効化します。

 ◆ マルチキャストルーティングの有効化
 (config)# ip multicast-routing

 次に、インターフェースでPIM-SMを有効にします。BSRの場合はSparseモードの設定を行います。

 
◆ マルチキャストパケットを転送させたいインターフェースでPIM-SMを有効化
 (config)#
interface interface-id
 (config-if)#
ip pim sparse-mode


 BSRを設定するためには「RP Candidateの設定」と「BSR Candidateの設定」が必要となります。

 
◆ RP Candidate(RP候補)の設定
 (config)#
ip pim rp-candidate interface-id [ group-list ACL ] [ interval seconds ] [ priority priority ]

コマンド引数 説明
interface-id  RPのアドレスにするインターフェースの指定
ACL  マルチキャストグループを指定するための標準ACLの番号
seconds  RP-Announceメッセージを送信する間隔( デフォルト値は60秒 )
priority  RPのプライオリティ値(小さい値が優先される。デフォルトは 0 )

 ※ ACLを指定しない場合、全てのマルチキャストグループの共通のRPアドレスのコンフィグ設定となります。


 
◆ BSR Candidate(BSR候補)の設定
 (config)#
ip pim bsr-candidate interface-id hash-mask priority

コマンド引数 説明
interface-id  BSRのアドレスにするインターフェースの指定
hash-mask  グループアドレスとのAND条件となるマスク長を指定 ※1( デフォルトは 0 )
priority  BSR Candidateのプライオリティ値(大きい値が優先される。デフォルトは 0 )

 ※1 ハッシュ元が同じであるすべてのグループは、同じRPに対応します。


 ◆ PIM-SMの設定 - BSRの設定例

 それでは、下図におけるコンフィグ設定例を紹介します。


    



 R1(config)# ip multicast-routing

 R1(config)# interface GigabitEthernet0/0
 R1(config-if)# ip address 10.1.1.254 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface GigabitEthernet0/2
 R1(config-if)# ip address 192.168.2.1 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface GigabitEthernet0/3
 R1(config-if)# ip address 192.168.3.1 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface loopback0
 R1(config-if)# ip address 1.1.1.1 255.255.255.255
 R1(config-if)# ip pim sparse-mode

 R1(config)# ip pim bsr-candidate loopback0


 R2(config)# ip multicast-routing

 R2(config)# interface GigabitEthernet0/1
 R2(config-if)# ip address 192.168.2.2 255.255.255.0
 R2(config-if)# ip pim sparse-mode

 R2(config)# interface GigabitEthernet0/2
 R2(config-if)# ip address 192.168.4.2 255.255.255.0
 R2(config-if)# ip pim sparse-mode

 
R2(config)# interface loopback0
 
R2(config-if)# ip address 2.2.2.2 255.255.255.255
 
R2(config-if)# ip pim sparse-mode

 
R2(config)# access-list 1 permit 239.1.1.5

 R2(config)# ip pim rp-candidate loopback0 group-list 1


 R3(config)# ip multicast-routing

 R3(config)# interface GigabitEthernet0/0
 R3(config-if)# ip address 172.16.1.254 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# interface GigabitEthernet0/1
 R3(config-if)# ip address 192.168.3.3 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# interface GigabitEthernet0/2
 R3(config-if)# ip address 192.168.4.3 255.255.255.0
 R3(config-if)# ip pim sparse-mode




マルチキャスト - Ciscoコンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.