Multicast Bidir-PIM Config



 ◆ PIM-SMの設定 - Bidir-PIM

 PIM-SMにおいて、Bidir-PIMを動作させるために先ずマルチキャストルーティングを有効化します。

 ◆ マルチキャストルーティングの有効化
 (config)# ip multicast-routing

 次に、インターフェースでPIM-SMを有効にします。今回はBSRで、RPアドレスを学習することにします。
 BSR候補、PR候補のアドレスをloopback I/Fとした場合、そのloopback I/FでもPIM-SMを有効化します。

 
◆ マルチキャストパケットを転送させたいインターフェースでPIM-SMを有効化
 (config)#
interface interface-id
 (config-if)#
ip pim sparse-mode


 全てのマルチキャストルータでBidir-PIMを有効化させる設定をします。それは以下の1行です。

 
◆ Bidir-PIM有効化の設定
 (config)#
ip pim bidir-enable


 BSRを設定するためには「RP Candidateの設定」と「BSR Candidateの設定」が必要となります。そして
 Bidir-PIMでルーティングを行うようにRP Candidateの設定において「
bidir」オプションを付加させます。

 
◆ RP Candidateの設定
 (config)#
ip pim rp-candidate interface [ group-list ACL ] [ interval seconds ] [ priority priority ] bidir

コマンド引数 説明
interface-id  RPのアドレスにするインターフェースの指定
ACL  マルチキャストグループを指定するための標準ACLの番号
seconds  RP-Announceメッセージを送信する間隔( デフォルト値は60秒 )
priority  RPのプライオリティ値(小さい値が優先される。デフォルトは 0 )
bidir  マルチキャストアドレスをBidir-PIMでルーティングするための設定

 ※ ACLを指定しない場合、全てのマルチキャストグループの共通のRPアドレスのコンフィグ設定となります。


 ◆ BSR Candidateの設定
 (config)#
ip pim bsr-candidate interface-id hash-mask priority

コマンド引数 説明
interface-id  BSRのアドレスにするインターフェースの指定
hash-mask  RPを決定するためのハッシュ値の計算で利用するハッシュマスク長(デフォルトは 0 )
priority  BSR Candidateのプライオリティ値(大きい値が優先される。デフォルトは 0 )




 RPの学習方法は、通常のPIM-SM同様に「スタティックRP」「Auto-RP」「BSR」の3パターンがあります。
 今回はBSRを前提に解説しましたが、その他の設定でも
bidir オプションを指定することが必要となります。

 
◆ スタティックRPの設定例
 R1(config)# ip pim rp-address 2.2.2.2 bidir


 ◆ Auto-RPの設定例
 R1(config)# ip pim send-rp-announce loopback0 scope 16 group-list 1 bidir


 ◆ BSRの設定例
 R1(config)# ip pim rp-candidate loopback0 group-list 1 bidir


 ◆ PIM-SMの設定 - Bidir-PIMの設定例

 それでは、下図におけるコンフィグ設定例を紹介します。下図ではBidir-PIMを有効化させることによって
 共有ツリーのみでマルチキャストルーティングを行っています。なお、実際には下図のような構成において
 Bidir-PIMを有効化させる意味はありませんが、コンフィグを分かりやすくするため下図に適用しています。


    


 上図で、Bidir-PIM( ip pim bidir-enable )を有効化させない場合は、SPTスイッチオーバーによって
 R1 ⇒ R3 というパスの順番でマルチキャストパケットを転送しますが、Bidir-PIMを有効化させた結果、
 共有ツリーのみでマルチキャストルーティングを行うので、R1⇒R2⇒R3のパスでパケット転送をします。


 R1(config)# ip multicast-routing

 R1(config)# interface GigabitEthernet0/0
 R1(config-if)# ip address 10.1.1.254 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface GigabitEthernet0/2
 R1(config-if)# ip address 192.168.2.1 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface GigabitEthernet0/3
 R1(config-if)# ip address 192.168.3.1 255.255.255.0
 R1(config-if)# ip pim sparse-mode

 R1(config)# interface loopback0
 R1(config-if)# ip address 1.1.1.1 255.255.255.255
 R1(config-if)# ip pim sparse-mode

 R1(config)# ip pim bsr-candidate loopback0

 R1(config)# ip pim bidir-enable


 R2(config)# ip multicast-routing

 R2(config)# interface GigabitEthernet0/1
 R2(config-if)# ip address 192.168.2.2 255.255.255.0
 R2(config-if)# ip pim sparse-mode

 R2(config)# interface GigabitEthernet0/2
 R2(config-if)# ip address 192.168.4.2 255.255.255.0
 R2(config-if)# ip pim sparse-mode

 
R2(config)# interface loopback0
 
R2(config-if)# ip address 2.2.2.2 255.255.255.255
 
R2(config-if)# ip pim sparse-mode

 
R2(config)# access-list 1 permit 239.1.1.5
 R2(config)# ip pim rp-candidate loopback0 group-list 1 bidir

 R2(config)# ip pim bidir-enable


 R3(config)# ip multicast-routing

 R3(config)# interface GigabitEthernet0/0
 R3(config-if)# ip address 172.16.1.254 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# interface GigabitEthernet0/1
 R3(config-if)# ip address 192.168.3.3 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# interface GigabitEthernet0/2
 R3(config-if)# ip address 192.168.4.3 255.255.255.0
 R3(config-if)# ip pim sparse-mode

 R3(config)# ip pim bidir-enable


  

 共有ツリー(*,239.1.1.5)において、RP方向のGi0/2が「Bidir-Upstream」であることを確認しましょう。


 ◆ ステータス確認における確認ポイント

確認コマンド 説明
show ip mroute x.x.x.x  Bidir-PIMの場合、Incoming Interface(RPF interface)はBidir-Upstreamと表示される
show ip pim rp mapping  RPアドレスの右側に「 bidir 」と表示される
show ip pim interface df x.x.x.x  冗長化されたLANセグメントにおいて「 DF Winner 」がどのアドレスなのかを確認できる



マルチキャスト - Ciscoコンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.