ip multicast rate-limit



 ◆ マルチキャスト - レート制限

 マルチキャストのコンフィグ設定において、Senderとなる配信サーバからのマルチキャストトラフィックの
 レート制限を行うことができます。レート制限の設定はインターフェース上で行って、そのインターフェース
 において、マルチキャストトラフィックの使用帯域を制限することができます。


 ◆ マルチキャスト - レート制限の設定
 (config)# interface interface-id
 (config-if)#
ip multicast rate-limit [ in | out ] [ video | whiteboard ] [ group-list ACL1 ]
       [
source-list ACL2 ] kbps

コマンド引数 説明
in  レート制限を着信に適用( kbpsパラメータで適用した値のレートでマルチキャストパケットを受信)
out  レート制限を発信に適用( kbpsパラメータで適用した値のレートでマルチキャストパケットを発信)
video  オプション設定。SAPで学習したビデオトラフィックで使用されるUDPポートに基づきレート制限
whiteboard  オプション設定。SAPで学習したwhiteboardトラフィックで使用されるUDPポートに基づきレート制限
group-list ACL1  マルチキャストグループ(マルチキャストアドレス)を指定するためのACL
source-list ACL1  マルチキャストパケットを送信するSenderを指定するためのACL
kbps  レート制限を「kbps」の単位で指定。この値よりも大きなトラフィックレートのパケットは破棄される


 デフォルトでレート制限のコンフィグは設定されていないため、レート制限を受けることなくマルチキャスト
 トラフィックをルータは転送することができます。なお、ip multicast rate-limitコマンドで「kbps」の値を
 0 とした場合、あらゆるレートのマルチキャストトラフィックは転送が許可されません。


 ◆ マルチキャスト - レート制限 - 設定例

 マルチキャストルータのGi0/0から送信するマルチキャストパケットにおいて、Senderが配置されている
 10.1.1.0/24のネットワークから送信されるマルチキャストトラフィック(239.0.0.0/24)を256Kbpsで
 レート制限する設定例は以下の通りです。


 
Cisco(config)# access-list 1 permit 239.0.0.0 0.0.0.255
 Cisco(config)# access-list 2 permit 10.1.1.0 0.0.0.255

 Cisco(config)# interface GigabitEthernet0/0
 Cisco(config-if)# ip multicast rate-limit out group-list 1 source-list 2 256



 マルチキャストトラフィックのレート制限は、ip multicast rate-limitコマンドを使用しなくても、QoSの
 ポリシング機能を実装することでも、マルチキャストトラフィックのレート制限を実現することができます。
 QoS設定に際して、簡単にQoS設定ができる設計となっている
MQC( Modular QoS CLI )を用いることに
 なりますが、そのMQCには次の3ステップが含まれます。

 Step1:
class-mapコマンドでトラフィッククラスを定義
 Step2:
policy-mapコマンドでQoS機能をトラフィッククラスに関連付け、トラフィック ポリシーを作成
 Step3:
service-policyコマンドで、インターフェイスにトラフィック ポリシーを割り当て

 以上のStepを踏まえて、以下の設定で上記の「ip multicast rate-limit」コマンドと同じ結果が得られます。


 Cisco(config)# access-list 101 permit ip 10.1.1.0 0.0.0.255 239.0.0.0 0.0.0.255

 
Cisco(config)# class-map match-all C-Multicast
 Cisco(config-cmap)# match ip address 101

 Cisco(config)# policy-map P-Multicast
 Cisco(config-pmap)# class C-Multicast
 Cisco(config-pmap-c)# police 256

 Cisco(config)# interface GigabitEthernet0/0
 Cisco(config-if)# service-policy output P-Multicast




マルチキャストの技術解説(応用)

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.