Multicast over GRE



 ◆ GREトンネル経由のマルチキャスト転送

 マルチキャストルーティングを実行するためには、SenderからReceiverまで全てのルータでマルチキャスト
 ルーティングを有効化させる必要があります。つまり、下図のようにマルチキャストを有効化できないような
 ネットワークがある場合、通常のルーティング設定ではマルチキャストパケットを転送することができません。



    



 上図のような構成で、SenderからReceiverへマルチキャストパケットを転送したい場合、マルチキャスト
 ルーティングが可能なドメインとユニキャストルーティングが可能なドメインの境界に位置するルータで、
 マルチキャストパケットをユニキャストパケットでカプセル化することで、ユニキャストしかルーティング
 できないネットワークでもマルチキャストパケットを転送できます。カプセル化は、GREによって行います。


    



 ◆ GREトンネル経由のマルチキャスト転送 - コンフィグ設定例

 下図を前提に設定例を紹介します。コンフィグ設定を簡素化するために「PIM-DM」の設定とします。


  


 RPFチェックの設定に注意する必要があります。239.1.1.5のマルチキャストパケットの送信元IPアドレスは
 Senderの「192.168.1.1」となりますが、R2にとって送信元IPアドレス「192.168.1.1」のRPF Interfaceは
 R2のGigabitEthernet0/0となります。しかし、GREトンネルによりマルチキャストパケットを転送している
 ことから、マルチキャストパケットを受信しているインターフェースは「Tunnel0」となります。したがって
 
ip mroute 192.168.1.0 255.255.255.0 Tunnel0 のコンフィグ設定がないとRPFチェックに失敗します。


 R1(config)# ip multicast-routing

 
R1(config)# interface GigabitEthernet0/1
 R1(config-if)# ip address 192.168.1.254 255.255.255.0
 R1(config-if)# ip pim dense-mode

 R1(config)# interface GigabitEthernet0/0
 R1(config-if)# ip address 10.1.1.1 255.255.255.0
 
R1(config-if)# ip pim dense-mode

 R1(config)# interface Tunnel0
 R1(config-if)# ip unnumbered GigabitEthernet0/0
 
R1(config-if)# tunnel source GigabitEthernet0/0
 
R1(config-if)# tunnel destination 10.2.2.2
 
R1(config-if)# ip pim dense-mode


 R1(config)# router ospf 1
 R1(config-if)# network 192.168.1.254 0.0.0.0 area 0
 R1(config-if)# network 10.1.1.1 0.0.0.0 area 0


 R2(config)# ip multicast-routing

 
R2(config)# interface GigabitEthernet0/1
 R2(config-if)# ip address 172.16.1.254 255.255.255.0
 R2(config-if)# ip pim dense-mode

 R2(config)# interface GigabitEthernet0/0
 R2(config-if)# ip address 10.2.2.2 255.255.255.0
 
R2(config-if)# ip pim dense-mode

 R2(config)# interface Tunnel0
 R2(config-if)# ip unnumbered GigabitEthernet0/0
 
R2(config-if)# tunnel source GigabitEthernet0/0
 
R2(config-if)# tunnel destination 10.1.1.1
 
R2(config-if)# ip pim dense-mode


 R2(config)# router ospf 1
 R2(config-if)# network 172.16.1.254 0.0.0.0 area 0
 R2(config-if)# network 10.2.2.2 0.0.0.0 area 0

 R2(config)# ip mroute 192.168.1.0 255.255.255.0 Tunnel0



 R2で「ip mroute」コマンドを設定することで、以下の通りRPFインターフェースが「Tunnel0」となります。

 


 なお、本技術を検証する場合には、R1とR2の間に1台のルータを挟んで動作確認するようにしましょう。



マルチキャストの技術解説(応用)

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.