NAT - TCP Load Distribution



 ◇ 前提として、このようなレガシー機能の利用はお勧めしません。分散処理にはLBの導入が必須です。

 ◆ TCPロードディストリビューション

 TCPロードディストリビューションはスタティックNATの拡張機能であり、1つのグローバルアドレスを
 複数の内部アドレスにマッピングさせて、それらの複数のホストにTCPセッションを分散させられます。
 下図では、1つのグローバル仮想アドレス(10.10.10.10)を(10.10.10.1 〜 3)の3つにマッピング。


  



 Cisco(config) # interface GigabitEthernet0/0
 Cisco(config-if) # ip address 100.100.100.1 255.255.255.248
 Cisco(config-if) # ip nat outside

 Cisco(config) # interface GigabitEthernet0/1
 Cisco(config-if) # ip address 10.10.10.254 255.255.255.0
 Cisco(config-if) # ip nat inside

 Cisco(config) # ip nat pool T-load 10.10.10.1 10.10.10.3 netmask 255.255.255.0 type rotary
 Cisco(config) # access-list 1 permit host 10.10.10.10

 Cisco(config) # ip nat inside destination list 1 pool T-load


 
アドレス変換時にプールされているアドレス( 10.10.10.1 〜 3 )を順番に使用するようにするためには
 
rotaryキーワードを入力する必要があります。この設定で、宛先アドレス( 10.10.10.10 )のパケットが
 着信した時、アドレス変換は 10.10.10.1 → 10.10.10.2 → 10.10.10.3 → 10.10.10.1 の順番で変換後の
 アドレスが切り替わることによりトラフィックを分散させることが可能になります。ただし、実サーバが
 ダウンしても、
ダウンした対象にもセッションを開始させます。また、対象トラフィックはTCPだけです。


 
◆ 200.20.200.1 の外部ホストから「10.10.10.10:23」に複数のセッションを確立した時の show ip nat translation の結果

show ip nat translation の出力結果
Pro Inside global Inside local Outside local Outside global
tcp 10.10.10.10:23 10.10.10.1:23 200.200.200.1:1039 200.200.200.1:1039
tcp 10.10.10.10:23 10.10.10.2:23 200.200.200.1:1040 200.200.200.1:1040
tcp 10.10.10.10:23 10.10.10.3:23 200.200.200.1:1041 200.200.200.1:1041



NATの技術

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.