NAT - Route-map



 ◆ Route-mapを使用したスタティックNAT

 Route-mapを使用したスタティックNATを実装することで、
宛先ごとに異なる送信元アドレスに変換
 することができます。下図を例にRoute-mapを使用したスタティックNATの設定例を見てみましょう。

 内部ネットワークのホスト「192.168.1.10」から、宛先ネットワーク「10.2.2.0/24」と通信する場合、
 Gi 0/1のセグメントのIPアドレスに送信元アドレスを変換して通信を行って、インターネット通信する
 場合には、Gi 0/2のセグメントのIPアドレスに送信元アドレスを変換して通信する設定例は以下の通り。


  


 Cisco(config) # interface GigabitEthernet0/0
 Cisco(config-if) # ip address 192.168.1.254 255.255.255.0
 Cisco(config-if) # ip nat inside

 Cisco(config) # interface GigabitEthernet0/1
 Cisco(config-if) # ip address 10.1.1.254 255.255.255.0
 Cisco(config-if) # ip nat outside

 
Cisco(config) # interface GigabitEthernet0/2
 
Cisco(config-if) # ip address 20.1.1.254 255.255.255.0
 
Cisco(config-if) # ip nat outside


 Cisco(config) #
access-list 101 permit ip 192.168.1.0 0.0.0.255 10.2.2.0 0.0.0.255
 
Cisco(config) # access-list 102 permit ip 192.168.1.0 0.0.0.255 any

 Cisco(config) # route-map PRIVATE permit 10
 Cisco(config-route-map) # match ip address 101
 Cisco(config-route-map) # set ip next-hop 10.1.1.253

 Cisco(config) # route-map INTERNET permit 10
 Cisco(config-route-map) # match ip address 102
 Cisco(config-route-map) # set ip next-hop 20.1.1.253

 Cisco(config) # ip nat inside source static 192.168.1.10 10.1.1.20 route-map PRIVATE
 
Cisco(config) # ip nat inside source static 192.168.1.10 20.1.1.20 route-map INTERNET


 ◆ 
ip nat inside source static 192.168.1.10 10.1.1.20 route-map PRIVATE
 ⇒ ルートマップ「PRIVATE」に合致したトラフィックに対して実行するスタティックNATの設定

 ◆ ip nat inside source static 192.168.1.10 20.1.1.20 route-map INTERNET
 ⇒ ルートマップ「INTERNET」に合致したトラフィックに対して実行するスタティックNATの設定

 このようにRoute-mapを使用したスタティックNATでは、同じローカルアドレスに宛先に応じた複数の
 グローバルアドレスをマッピングすることができます。つまり「宛先ベースのスタティックNAT」です。



NATの技術

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.