NAT & PAT - show ip nat translations



 ◆ スタティックNAT - NATテーブルの確認

 ◆ スタティックNATの設定例

 Cisco(config) #
ip nat inside source static 192.168.0.1 100.1.1.1

 Cisco(config) # interface GigabitEthernet0/1
 Cisco(config-if) # ip nat inside

 
Cisco(config) # interface GigabitEthernet0/0
 
Cisco(config-if) # ip nat outside


 上記のコンフィグ設定をした場合、NATテーブルを表示させると以下の結果となります。NATテーブルを
 確認するコマンドは
show ip nat translations です。スタティックNATでは、NAT変換させた通信をして
 いなくても、コンフィグ設定した時点で以下の通り自動的にNATテーブルにNAT変換情報が表示されます。

 



 ◆ ダイナミックNAT - NATテーブルの確認

 ◆ ダイナミックNATの設定例

 Cisco(config) #
ip nat pool TEST 100.1.1.1 100.1.1.6 netmask 255.255.255.248
 Cisco(config) # access-list 1 permit 192.168.0.0 0.0.0.255
 Cisco(config) # ip nat inside source list 1 pool TEST

 Cisco(config) # interface GigabitEthernet0/1
 Cisco(config-if) # ip nat inside

 
Cisco(config) # interface GigabitEthernet0/0
 
Cisco(config-if) # ip nat outside


 上記の設定をした場合、NATテーブルを表示させると以下の結果となります。show ip nat translationsで
 確認しても、NAT変換を行う通信をさせていない状態ではダイナミックNATの場合は何も表示されません。

 



 そこで192.168.0.1のクライアントPCから200.1.1.2のWebサーバへHTTP接続の通信を発生させてみます。
 すると、以下のようにNATテーブルが表示されます。※機種やIOSバージョンによりNATテーブルは以下の
 ように表示されず「内部グローバル」と「内部ローカル」のアドレスだけが(3行目だけが)表示されます。

 

項番 項目 説明
@  Pro  プロトコル
A  Inside global  内部グローバルアドレス + 送信元ポート番号
B  Inside local  内部ローカルアドレス + 送信元ポート番号
C  Outside local  外部ローカルアドレス + 宛先ポート番号
D  Outside global  外部グローバルアドレス + 宛先ポート番号


 ◆ PAT - NATテーブルの確認

 ◆ PATの設定例

 Cisco(config) #
access-list 1 permit 192.168.0.0 0.0.0.255
 Cisco(config) # ip nat inside source list 1 interface GigabitEthernet0/0 overload

 Cisco(config) # interface GigabitEthernet0/1
 
Cisco(config-if) # ip address 192.168.0.254 255.255.255.0
 Cisco(config-if) #
ip nat inside

 
Cisco(config) # interface GigabitEthernet0/0
 
Cisco(config-if) # ip address 100.1.1.1 255.255.255.0
 Cisco(config-if) # ip nat outside


 上記の設定をした場合、NATテーブルを表示させると以下の結果となります。show ip nat translationsで
 確認しても、NAT変換を行う通信をさせていない状態ではダイナミックNATと同様に何も表示されません。

 そこで192.168.0.1のクライアントPCから200.1.1.2のWebサーバへHTTP接続の通信を発生させてみます。
 すると以下のようにNATテーブルが表示されます。NATテーブルの見方はダイナミックNATの時と同じです。

 

項番 項目 説明
@  Pro  プロトコル
A  Inside global  内部グローバルアドレス + 送信元ポート番号
B  Inside local  内部ローカルアドレス + 送信元ポート番号
C  Outside local  外部ローカルアドレス + 宛先ポート番号
D  Outside global  外部グローバルアドレス + 宛先ポート番号




 ◆ NATアドレス変換の統計情報

 NAT変換、またはPAT変換によるアドレス変換の統計情報は、show ip nat statisticsで確認できます。

 

項番 項目 説明
@

 Total active translations: 3
 (1 static, 2 dynamic; 2 extended)

 現在アクティブなNAT変換エントリの数。ここでは、スタティックNATの
 変換エントリが1つ、ダイナミックNATまたはPATの変換エントリが2つを示す。

A  Outside interfaces:
 FastEthernet0
 外部ネットワークのインターフェースを示す。
B  Inside interfaces:
 FastEthernet1
 内部ネットワークのインターフェースを示す。
C  Hits: 559 Misses: 130

 NATテーブルを参照し変換エントリの検索に成功(Hits)、失敗(Misses)した回数

D  Expired translations: 45  NAT変換エントリがタイムアウトによりクリアされた回数




 ◆ NAT - デバッグの見方

 NATを設定したルータで debug ip nat を入力すると、リアルタイムに変換情報を確認できます。

 


 1. 行きのパケット(送出されたパケット)
 送信元IPアドレスが「192.168.0.1」から「100.1.1.1」へ変換されて、宛先IPアドレス「200.1.1.2」へ
 通信しようとしています。“ s= ” は送信元IPアドレス、“ d= ” は宛先IPアドレス、“ -> ”は変換を示す。

 2. 帰りのパケット(着信してきたパケット)
 100.1.1.1 からのパケットを受信した 200.1.1.2 のサーバが、自身の送信元アドレス「200.1.1.2」から
 宛先アドレス「100.1.1.1」へパケットを送信しています。宛先アドレス「100.1.1.1」としてパケットを
 受信したNATルータは宛先アドレス「100.1.1.1」を「192.168.0.1」へ変換して(戻して)いる事を示す。

 ※ 各エントリの最後の [ 17399 ] は、IOSにより自動的に割り当てられるパケットの関連性を示す番号。



NAT、PAT

ネットワークエンジニアとして

Copyright (C) 2002-2021 ネットワークエンジニアとして All Rights Reserved.