Cisco Nexus - FEX ( Fabric Extender )



 ◆ FEXとは

 FEXとはCisco Nexus2000 Series
Fabric Extenderのことです。Nexus2000シリーズは単独では動作せず
 Nexus7000シリーズまたはNexus5500シリーズを親(CPU)にすることにより(接続することで)動作します。
 具体的には、Nexus7000 or 5500シリーズとNexus2000と間を
10Gケーブルで相互接続することによって
 Nexus2000スイッチを1つのラインカードとして使用します。従ってNexus2000スイッチにはソフトウェアは
 インストールされておらず、ソフトウェアは親デバイスから自動的にダウンロード、アップグレードされます。



 ◆ FEXの用語

 ◇ 
ファブリックインターフェース
 FEXから親スイッチへ接続するための専用10GEのアップリンクポート。親スイッチに直接接続の必要あり。

 ◇ 
ポートチャネルのファブリックインターフェース
 FEXから親スイッチへのポートチャネルのアップリンク接続。単一の論理チャネルにI/Fをバンドルし構成。

 ◇ 
ホストインターフェース
 サーバまたはホストが接続するためのインターフェース
 
※ FEXに接続する対向機器でBPDUを無効にすれば、スイッチを接続できるが、ホストインターフェースに接続することは非推奨。

 ◇ 
ポートチャネルのホストインターフェース
 サーバまたはホストとの接続に使用するポートチャネルのホストインターフェース。



 ◆ デバイスをFEXホストインターフェースに接続する時のガイドライン(仕様)

 @ 全てのFEXホストインターフェースはBPDUガードがイネーブルになったSTPエッジポートとして実行。
 A FEXホストインターフェースがBPDUを受信するとそのインターフェースは
err-disableステートになる。
 B 802.3adポートチャネル、Active/Standbyチーミング、その他のホストベースのリンク冗長性の技術を
   利用するサーバは、FEXホストインターフェースに接続することができる。
 C Flexリンク、vPCなどのSTPに依存していないエッジスイッチはFEXホストインターフェースに接続可能。

 ※ FEXの設定は全て親スイッチ(Nexus7000 or 5500)で実施。Nexus2000はあくまでもラインカードです。


 ◆ FEXの設定 - イーサネットインターフェースとのアソシエーション

 
@ FEX機能のサービス有効化 ( デフォルトでは無効化 )
 (config)# feature fex

 
A 外部ファブリックエクステンダ―をサポートするようにインターフェースを設定 ( 例 e1/1 に設定 )
 (config)# interface ethernet 1/1
 
(config-if)# switchport mode fex-fabric

 
B 親スイッチのインターフェースに接続されているN2000にFEX-numberをアソシエート。100〜199 の範囲 ( 例 101を使用 )
 (config-if)# fex associate 101


 
N5K-1(config)# feature fex

 N5K-1(config)# interface ethernet 1/1
 N5K-1(config-if)# switchport mode fex-fabirc
 N5K-1(config-if)# fex associate 101


 
※ show interface ethernet 1/1 fex-intf コマンドにより、親デバイスとFEX装置とのアソシエーションを確認できる。




 ◆ FEXの設定 - ポートチャネルへのFEXの関連付け

 
@ 物理インターフェースにポートチャネルを割り当て ( 例 : 1/1と1/2に、Port-Channel 101を割り当て )
 (config)# interface ethernet 1/1
 
(config-if)# channel-group 101
 
(config-if)# no shutdown

 
(config)# interface ethernet 1/2
 
(config-if)# channel-group 101
 
(config-if)# no shutdown

 
A ポートチャネルのモードをfex-fabricとして、FEX番号を指定、vPCの指定
 (config)# interface port-channel 101
 
(config-if)# switchport
 
(config-if)# switchport mode fex-fabric
 
(config-if)# fex associate 101
 
(config-if)# vpc 101


 
N5K-1(config)# interface ethernet 1/1
 N5K-1(config-if)# channel-group 101

 N5K-1(config)# interface ethernet 1/2
 N5K-1(config-if)# channel-group 101

 N5K-1(config)# interface port-channel 101
 N5K-1(config-if)# switchport
 N5K-1(config-if)# switchport mode fex-fabirc
 N5K-1(config-if)# fex associate 101
 N5K-1(config-if)# vpc 101




 ◆ FEXの設定 - グローバル機能の設定

 
@ 指定したFEXコンフィグレーションモードの開始
 (config)# fex 101

 
A 任意 : FEXタイプの指定( N2224TP、N2232P、N2232TP、N2232TT、N2248T、NB22HP、NB22FTS、NB22DELLなど )
 ⇒ この機能を設定すると、設定されたFEXタイプに一致するFEXが接続された場合にのみオンラインになります。
 (config)# fex 101


 N5K-1(config)# fex 101
 
N5K-1(config-fex)# type N2248T



 ◆ FEXの設定 - Nexus2000スイッチポートの設定

 FEX接続されたNexus2000側のスイッチポートのインターフェース番号は、ethernet 101/1/1 のように
 FEX番号 + ポート番号という形で指定。FEX番号101のNexus2000の1番ポートへの設定は以下の通りです。


 N5K-1(config)# interface ethernet 101/1/1
 
N5K-1(config-if)# switchport access vlan 200
 N5K-1(config-if)# speed 1000
 N5K-1(config-if)# duplex full




Cisco Nexus - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.