Cisco Nexus - L2/L3 interface / HSRP



 ◆ Cisco Nexus - L3インターフェースの設定

 
@ L3インターフェースの設定
 (config)# interface ethernet 1/1
 
(config-if)# no switchport

 
A IPアドレスの設定
 (config-if)# ip address 192.168.0.1/24

 
B 任意 : インターフェースメディア ( broadcastまたはp2p ) の設定。デフォルトはbroadcast
 (config-if)# medium broadcast


 
Nexus(config)# interface ethernet 1/1
 Nexus(config-if)# no switchport
 Nexus(config-if)# ip address 192.168.0.1/24




 ◆ Cisco Nexus - サブインターフェースの設定

 
@ サブインターフェースの設定
 (config)# interface ethernet 1/1
 
(config-if)# encapsulation dot1Q 100

 
A IPアドレスの設定
 (config-if)# ip address 192.168.0.1/24


 
Nexus(config)# interface ethernet 1/1
 Nexus(config-if)# encapsulation dot1Q 100
 Nexus(config-if)# ip address 192.168.0.1/24



 ◆ Cisco Nexus - VLANインターフェースの設定

 
@ interface-vlan Featureの有効化
 (config)# feature interface-vlan

 
A VLANの作成
 (config)# vlan 10

 
B VLANインターフェースの作成とIPアドレスの設定
 (config)# interface vlan 10
 
(config-if)# ip address 192.168.0.1/24


 
Nexus(config)# feature interface-vlan

 Nexus(config)# vlan 10

 Nexus(config)# interface vlan 10
 Nexus(config-if)# ip address 192.168.0.1/24




 ◆ Cisco Nexus - VRFへのインターフェースの割り当て

 
@ インターフェースの指定とVRFへの割り当て (例 e1/1 に"GROUP1"というVRF名を設定 )
 (config)# interface ethernet 1/1
 
(config-if)# vrf member GROUP1

 
A IPアドレスの設定
 (config-if)# ip address 192.168.0.1/24


 
Nexus(config)# interface ethernet 1/1
 Nexus(config-if)# vrf member GROUP1
 Nexus(config-if)# ip address 192.168.0.1/24



 ◆ NX-OS - HSRPの設定

 
◆ HSRPデフォルト値
HSRPパラメータ デフォルト値
HSRP  ディセーブル
認証  version 1 の場合はテキストとしてイネーブル。パスワードは cisco
HSRPバージョン  version 1
プリエンプト  ディセーブル
プライオリティ  100
仮想MACアドレス  HSRPグループ番号から生成される


 @ HSRPサービスの有効化
 (config)# feature hsrp

 
A HSRPを稼働させるL3インターフェースの指定
 (config)# interface vlan 10

 
B HSRPグループの指定
 ⇒ HSRPバージョン1の場合は"0 〜255"、HSRPバージョン2の場合は"0〜4095"を指定
 (config-if)# hsrp 10

 
C 任意 : HSRPのバージョンの設定 ( デフォルト値は 1 )
 (config-if)# hsrp version 2

 
D 仮想IPアドレスの設定
 (config-if)# ip 192.168.0.254

 
E インターフェースの有効化
 (config-if)# no shutdown


 
Nexus(config)# feature hsrp

 Nexus(config)# interface vlan 10
 Nexus(config-if)# hsrp 2
 Nexus(config-if-hsrp)# ip 192.168.0.254
 Nexus(config-if-hsrp)# exit
 Nexus(config-if)# no shutdown




 ※ show hsrp によりHSRPのステータスを確認できます。HSRPの基本は「 HSRPとは 」をご参考ください。



Cisco Nexus - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.