Cisco Nexus - config sample 1



 ◆ Nexus5500/5600 ⇔ Nexus2000 vPC/FEX/HSRP設定 その1

 ※ 検証機器はNexus5500を使用していますが、本内容はNexus5600にも適用できる設定例です。


   




 Nexus5500とNexus2000とをFEX接続した時の
 設定例を紹介。vPC、FEXなどを設定する場合
 色々なパラメーターが混在することになるので、
 設定ミスを防ぎ、快適な運用を実現するために
 以下の3つの値は同じになるように設定する事
 をお勧めします。そうするベンダーは多いです。

 ・ vPC番号
 ・ ポートチャネル番号
 ・ FEX番号

 例えば、VLAN番号とIPアドレスの第三オクテット
 とを同じ値にするのと同じような感覚です。ぜひ。



 ◆ mgmtインターフェースの設定

 
◇ N5K-1 のコンフィグ

 interface mgmt0
  ip address 192.168.0.1/24
  no shutdown


 ◇ N5K-2 のコンフィグ

 interface mgmt0
  ip address 192.168.0.2/24
  no shutdown



 ◆ vPCの設定 その1

 ◇ N5K-1 のコンフィグ

 feature vpc

 vpc domain 1
  peer-switch
  role priority 100
  peer-keepalive destination 192.168.0.2 source 192.168.0.1
  peer-gateway
  auto-recovery
  ip arp synchronize



 ◇ N5K-2 のコンフィグ

 feature vpc

 vpc domain 1
  peer-switch
  role priority 200
  peer-keepalive destination 192.168.0.1 source 192.168.0.2
  peer-gateway
  auto-recovery
  ip arp synchronize



 ◆ vPCの設定 その2

 
◇ N5K-1 のコンフィグ

 feature lacp

 interface Ethernet1/31
  switchport mode trunk
  channel-group 1 mode active

 interface Ethernet1/32
  switchport mode trunk
  channel-group 1 mode active


 interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  speed 10000
  vpc peer-link


 ◇ N5K-2 のコンフィグ

 feature lacp

 interface Ethernet1/31
  switchport mode trunk
  channel-group 1 mode active

 interface Ethernet1/32
  switchport mode trunk
  channel-group 1 mode active


 interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  speed 10000
  vpc peer-link



 ◆ インターフェースVLANの作成

 ◇ N5K-1 のコンフィグ

 vlan 101
 vlan 102

 feature interface-vlan

 interface Vlan101
 
 no shutdown
  ip address 192.168.101.1/24

 interface Vlan102
  no shutdown
  ip address 192.168.102.1/24



 ◇ N5K-2 のコンフィグ

 vlan 101
 vlan 102

 feature interface-vlan

 interface Vlan101
  no shutdown
 
 ip address 192.168.101.2/24

 interface Vlan102
  no shutdown
  ip address 192.168.102.2/24





Cisco Nexus - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.