N2K-C2248PQ-10GE - QSFP



 ◆ N2K-C2248PQ-10GE - QSFP接続の注意点

 Nexus6000シリーズとN2K-C2248PQ-10GEのFEXをQSFPケーブルで接続する際に注意点があります。
 結論から言うと、Nexus6000シリーズとN2K-C2248PQ-10GEの間でQSFPケーブル接続でリンクアップ
 させるためには、ソフトウェア NX-OS上で設定が必要となります。今回はその設定方法を解説します。
 なお本内容はNexus6000シリーズだけでなくNexus5600シリーズにも適用できる内容です。検証済み。


    



 先ず、背景となるロジックは以下の通りです。

 The Cisco Nexus 2248PQ FEX has sixteen 10-Gigabit Ethernet fabric interfaces via four Quad (4-channel) Small Form-factor
 Pluggable (QSFP) ports and forty-eight 10-Gigabit Ethernet host interfaces. All host interfaces use all of the available fabric
 interfaces. (Static pinning is not supported. Port-channel mode is only supported on fabric interfaces.) When all host
 interfaces send traffic to all fabric interfaces, the maximum oversubscription ratio for the Cisco Nexus 2248PQ is 3:1.



 ◆ N2K-C2248PQ-10GE - QSFP接続でリンクアップさせる設定

 上図の通りNexus5600シリーズのinterface 2/1にN2K-C2248PQ-10GEを接続するためには、40Gbpsの
 リンクを4つの10Gbpsリンクにいわば分離させる必要があります。しかもピンポイントに2/1だけ指定する
 ことはできないので、ここでは最小グループの2/1、2/2、2/3を4つの10Gbpsに分離させる設定をします。
 ※ 指定可能なオプションは1-3、4-6、7-9等です。10-12、1-6、7-12、4-9などは検証できていません。

 Nexus(config)# interface breakout slot 2 port 1-3 map 10g-4x


 上記コマンド設定後にモジュールの構成を変更するために該当スロットをリロードする必要があります。


 Nexus(config)# poweroff module 2
 Nexus(config)# no poweroff module 2


 最後に、分離された2/1/xの全てのインターフェースに対してコンフィグレーションを行えばOKです。


 interface Ethernet2/1/1
  switchport mode fex-fabric
  fex associate 11
  channel-group 11

 interface Ethernet2/1/2
  switchport mode fex-fabric
  fex associate 11
  channel-group 11

 interface Ethernet2/1/3
  switchport mode fex-fabric
  fex associate 11
  channel-group 11

 interface Ethernet2/1/4
  switchport mode fex-fabric
  fex associate 11
  channel-group 11


 interface port-channel11
  switchport mode fex-fabric
  fex associate 11
  vpc 11



   



Cisco Nexus - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.