Cisco Nexus - VLAN / VTP / RSTP



 ◆ Cisco Nexus - VLAN番号のサポート範囲

 NexusではVLAN番号「1〜4094」がサポートされます。VLAN番号のサポート範囲の仕様は以下の通りです。

VLAN番号 範囲 用途
1 標準  default VLAN。使用はできるが変更や削除はできない
2 〜 1005 標準  作成、使用、変更、削除可能なVLAN。
1006 〜 4094 拡張  作成、命名可能なVLAN。ステートはイネーブルでアクティブになるVLAN。
3968 〜 4047、4094 内部割当  内部で使用するために割り当てられたVLAN。作成、削除、変更はできない。


 ◆ 設定例 : VLAN 10 の作成

 Nexus(config)# vlan 10
 Nexus(config-vlan)# name SALES


 ◆ 設定例 : Ethernet1/5 に "VLAN 10"を割り当てる設定

 Nexus(config)# interface ethernet 1/5
 Nexus(config-vlan)# switchport mode access
 Nexus(config-vlan)# switchport access vlan 10



 ◆ 設定例 : デフォルトで定義された予約済みVLAN (3968 〜 4047) を、VLAN (1006 〜 1085) に変更する例 (再起動が必要)

 Nexus(config)# system vlan 1006 reserve

 Nexus# copy running-config startup-config
 Nexus# reload


 確認コマンド : show vlan / show vlan summary / show system vlan reserved


 ◆ Cisco Nexus - VTPの仕様

 VTPでは同じVTPドメインのスイッチからトランクインターフェースを介してVLANデータベースを同期できる。
 トランクインターフェースは、「L2EtherChannelやvPC」が実装されていても問題なくVLANを同期できます。

 ○ VTPクライアントとして設定されたNexusスイッチでは、VLAN1〜1005の範囲のVLANを作成できない。
 ○ トランクインターフェースでは必ずVLAN1が許可されている必要がある。
 ○ show running-configurationを実行しても1 〜 1000のVLAN設定情報やVTP設定情報は表示されない。
 ○ vPCを導入する場合は、プライマリvPCスイッチとセカンダリvPCスイッチは同一の設定にする必要がある。
 ○ VTPプルーニングはサポートされない。
 ○ PVLANはスイッチがトランスペアレントモードである場合のみサポートされる。
 ○ VTPクライアン or サーバモードで設定されている場合、1002 〜1005のVLANは予約済みのVLANとなる。
 ○ VTPアドバタイズメントはNexus 2000シリーズのファブリックエクステンダのポートからは送信されない。

 VTPを利用するためには、featureコマンドで有効化する必要があります。
 VTPに関する設定をデフォルトに戻したい場合は no feature vtp の後、feature vtp とすれば元に戻ります。

 Nexus(config)# feature vtp


 ◆ 設定例 : VTPドメインを " INFRA"
 Nexus(config)# vtp domain INFRA


 ◆ 設定例 : VTP version 2
 Nexus(config)# vtp version 2


 ◆ 設定例 : VTPモードを "Server"
 Nexus(config)# vtp mode server


 ◆ 設定例 : VTPパスワードを "expert"
 Nexus(config)# vtp password expert

 確認コマンド : show vtp status / show vtp counters / show vtp interface / show vtp password



 ◆ Cisco Nexus - Rapid PVST+ の設定

 
◆ 設定例 : Nexusスイッチ上で Rapid PVST+ をイネーブルにする設定 ( デフォルト値なので設定不要 )
 Nexus(config)# spanning-tree mode rapid-pvst


 ◆ 設定例 : VLAN2でRapid PVST+をイネーブルに設定(デフォルトで Rapid PVST+ は全VLANでイネーブルになるので設定不要)
 Nexus(config)# spanning-tree vlan 2


 ◆ 設定例 : VLAN2におけるブリッジプライオリティを4096にする設定 ( VLANごとに設定する必要がある )
 Nexus(config)# spanning-tree vlan 2 priority 4096



 
◆ ポートコストの設定(任意)
 
アクセスポートではポートごとにポートコストを割り当てる。トランクポートではVLANごとにポートコストを割り当てる。

 
◆ 設定例 : トランクインターフェースでVLAN2に対してコスト値100を割り当てる設定

 Nexus(config)# interface ethernet 1/5
 Nexus(config-if)#
spanning-tree vlan 2 cost 100


 ◆ ポートプライオリティの設定(任意)
 
LANポートがアクセスポートならポートのプライオリティ値が使用され、トランクポートならVLANポートのプライオリティ値を使用。

 
◆ 設定例 : トランクインターフェースでVLAN2に対してポートプライオリティ値160を割り当てる設定

 Nexus(config)# interface ethernet 1/5
 Nexus(config-if)#
spanning-tree vlan 2 port-priority 160



 ◆ プロトコルの再開
 レガシーブリッジに接続されている場合、Rapid PVST+を実行しているNexusは、そのポートの1つに802.1D BPDUを送信できる。
 ただしそのレガシースイッチが指定スイッチではない場合、レガシースイッチがリンクから削除されたかどうかを認識できない。そこで
 スイッチ全体または指定したポートでプロトコルネゴシエーションを再開できる。強制的に隣接スイッチと再ネゴシエーションさせる。

 ◆ 設定例 : Ethernet 1/5 で Rapid PVST+ を再起動するコマンド
 Nexus# clear spanning-tree detected-protocol interface ethernet 1/5



Cisco Nexus - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.