OSPF - ip ospf network



 ◆ OSPF - ネットワークタイプの設定

 OSPFの場合は残念なことに、EIGRPのようにLayer2でのシームレスな接続を完全に実現できておりません。
 つまり、
Layer2に合わせたOSPFのネットワークタイプの設定が必要になってきます。ただし、メディアに
 あわせたネットワークタイプが自動的に設定されるのであまり意識されることはありません。しかし例えば
 以下の3つのなかで、NBMAトポロジーにおいては手動で変更する必要があるネットワークタイプがあります。

3つのトポロジー NWの例 ネイバー検出 DR/BDR の選出 Hello interval
ブロードキャストマルチアクセス LAN接続 自動 10
ポイントツーポイント PPP接続 自動 10
NBMA FR / ATM接続 modeによる modeによる modeによる



 ここでは、OSPFで定義できる5つのネットワークタイプの設定を見ていきます。Cisco IOSにて定義できる
 ネットワークタイプのコマンドは以下の5つがあり、各ネットワークタイプにおける動作は以下となります。
 以下の通り、ブロードキャストの有無がネイバー検出の有無に影響しており、マルチアクセスネットワーク
 の有無がDR/BDR選出の有無に影響しています。※ Point-to-Pointは1対1の関係なのでネイバーを自動検出。

 ◆ OSPFネットワークタイプの設定
 (config-if)#
ip ospf network mode

5つのネットワークタイプ設定 内容 隣接検出 DR選出
 ip ospf network broadcast  LANで自動的に適用されるコマンド 自動
 ip ospf network point-to-point  Point-to-Pointで自動的に適用されるコマンド 自動
 ip ospf network non-broadcast  NBMAで自動的に適用されるコマンド 手動
 ip ospf network point-to-multipoint  手動で入力しないと適用されないコマンド 自動
 ip ospf network point-to-multipoint nonbroadcast  手動で入力しないと適用されないコマンド 手動


 LANインタフェースでは「ip ospf network broadcast」と設定しなくても、自動的にこのコマンドが適用
 されています。Serial I/Fでは「encapsulation ppp」と設定すれば「ip ospf netowrk point-to-point」と
 設定しなくても自動的にこのコマンドが適用されて、「encapsulation frame-relay」と設定してNBMAと
 認識させれば「ip ospf network non-broadcast」と設定しなくても自動的にこのコマンドが適用されます。
 ※ FRのポイントツーポイントサブインターフェースでは「ip ospf netowrk point-to-point」となります。


 各インターフェースで適用されるデフォルトの ip ospf network コマンドは、デフォルト値の場合には表示
 されません。例えば、GigabitEthernet 0/0などで「ip ospf network broadcast」の設定は表示されません。
 現在のネットワークタイプを確認したい場合は
show ip ospf interface interface-id コマンドで確認します。




 ◆ OSPF - NBMAモードにおける手動ネイバーの設定

 NBMAのトポロジーでは、ブロードキャスト(マルチキャスト)がサポートされていないため、OSPFのHello
 パケットが到達しません。そこで手動でOSPFネイバーを定義する必要があります。ハブアンドスポーク構成
 において以下の
neighbor設定はハブ側だけに設定します。スポーク側にneighborで設定する必要はないです。

 ◆ OSPF - NBMAモードにおける手動ネイバーの設定
 (config)#
router ospf procces-id
 (config-router)# neighbor ipaddress priority priority cost cost [ database-filter all ]

コマンド引数 説明
ipaddress

 OSPFネイバールータのIPアドレス。

priority  OSPFネイバールータのプライオリティ値。プライオリティ値は 0。
cost  OSPFネイバールータのコスト値。1〜65535の間で割り当てる。
database-filter all  指定したOSPFネイバールータに対して、LSAの送信を停止するコマンド。


 ◆ NBMAトポロジーにおけるハブ側(R1)の設定例

 R1(config)# router ospf 1
 R1(config-router)#network 192.168.0.1 0.0.0.0 area 0
 R1(config-router)#network 192.168.1.254 0.0.0.0 area 1
 
R1(config-router)#neighbor 192.168.0.2

 
R1(config-router)#neighbor 192.168.0.3

 R1(config)# interface Serial0/0
 R1(config-if)#ip ospf priority 255


 ◆ NBMAトポロジーにおけるスポーク側(R2とR3)の設定例

 R2(config)# router ospf 1
 R2(config-router)#network 192.168.0.2 0.0.0.0 area 0
 R2(config-router)#network 192.168.2.254 0.0.0.0 area 2


 R2(config)# interface Serial0/0
 R2(config-if)#ip ospf priority 0



 R3(config)# router ospf 1
 R3(config-router)#network 192.168.0.3 0.0.0.0 area 0
 R3(config-router)#network 192.168.3.254 0.0.0.0 area 3


 R3(config)# interface Serial0/0
 R3(config-if)#ip ospf priority 0

 スポーク側のルータがDRにならないように、I/Fで「ip ospf priority 0」と設定しておく必要があります。



OSPF 設定:応用

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.