route-map - distribute-list



 ◆ distribute-listコマンドにroute-mapを適用した設定

 ルートマップを配布リスト(distribute-list)の設定に適用してフィルタリングする設定は以下となります。

 ◆ ルートマップの設定
 (config)# route-map map-tag permit | deny [ seq-number ]
 (config-route-map)#
match condition
 (config-route-map)#
set action

 
◆ ルートマップを適用するための distribute-list の設定
 (config)#
router protocol
 (config-router)#
distribute-list route-map map-tag [ in | out ]

matchコマンド 説明
 match ip address acl

 配布リストにおける対象ルートの合致条件に、ACLを使用

 match ip address prefix-list name  配布リストにおける対象ルートの合致条件に、Prefixを使用
 match interface interface-id  配布リストにおける合致条件に、interfaceを使用
 match tag name  配布リストにおける合致条件に、TAGを使用
 match metric metric  配布リストにおける合致条件に、メトリックを使用
 match route-type type  配布リストにおける合致条件に、ルートタイプを使用
 match ip next-hop acl  標準ACLで定義したアドレスのネクストホップとなっているルートが再配布対象
 match ip route-source acl  標準ACLで定義したアドレスのソースアドレスを持つルータのルートが再配布対象


 
上記で紹介したmatch route-typeコマンド指定するルートタイプには以下のようなものがあります。
 
(config-route-map)# match route-type local | internal | external [ type1 | type2 ] nssa-external

match route-typeコマンド 説明
 local

 ローカルに生成されたBGPルート

 internal  OSPFの内部ルート( エリア内ルート、エリア間ルート )
 external  OSPFの外部ルート、または、EIGRPの外部ルート
 external type 1  OSPFのタイプ 1 外部ルートにのみ一致
 external type 2  OSPFのタイプ 2 外部ルートにのみ一致
 nssa-external  OSPFのNSSAの外部ルート

setコマンド 説明
 set metric value

 matchコマンドの合致ルートに、ルートメトリック値を定義

 set metric-type value  matchコマンドの合致ルートに、再配布先のルーティングプロトコルのメトリックタイプを定義。
 set tag tag

 matchコマンドの合致ルートに、タグ値を定義



 ◆ route-map - distribute-listでの使用

 distribute-listでroute-mapを使用する設定手法は、IOSでは当初は実装されていなかったため、設定事例が
 その他のルートフィルタリングでは少ないのですが、EIGRPもOSPFもルートに対するタグ付けの設定事例が
 多いのでそれを紹介します。32ビットの整数の
ルートタグ(route tag)によって、任意のルートに識別子
 割り当てることが可能です。ルートに色を付けられるので、その情報に基づきフィルタリングなどが行えます。

 設定例 1:OSPFインバウンドフィルタリング
 OSPF外部LSAにはタグが存在します。タグの値は、プレフィックスがルーティングテーブルにインストール
 する前に検査されます。以下の設定例ではタグ値が 50 のOSPF外部プレフィックスはフィルタリングされて
 それ以外の全てのルートは受信する設定例です。※全てのルートは受信( route-map R-TAG01 permit 20 )


 Cisco(config)# route-map R-TAG01 deny 10
 Cisco(config-route-map)# match tag 50
 
 Cisco(config)# route-map R-TAG01 permit 20

 Cisco(config)# router ospf 1
 Cisco(config-router)# distribute-list route-map R-TAG01 in




 設定例 2:EIGRPルートをタグ付けしてからのアドバタイズ
 EIGRPルート「192.168.1.0/24」にタグ値30を割り当てしてから、隣接ルータにアドバタイズする設定例。


 R2(config)# ip prefix-list PRE01 permit 192.168.1.0/24

 R2(config)# route-map R-TAG01 permit 10
 R2(config-route-map)# match ip address prefix-list PRE1
 R2(config-route-map)# set tag 30
 
 R2(config)# route-map R-TAG01 permit 20

 R2(config)# router eigrp 1
 R2(config-router)# distribute-list route-map R-TAG01 out




 設定例 3:EIGRPルートのタグ値によるフィルタリング
 EIGRPルートのうち、タグ値30が割り当てられたルートは、隣接ルータにはアドバタイズしない設定例。


 R3(config)# route-map R-TAG01 deny 10
 R3(config-route-map)# match tag 30

 R3(config)# route-map R-TAG01 permit 20

 R3(config)# router eigrp 1
 R3(config-router)# distribute-list route-map R-TAG01 out





ルート再配布とルート制御( redistribute、distribute-list、route-map、distance )

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.