VLAN Routing - Cisco Router subinterface



 ◆ サブインターフェースを使用したVLANルーティングの設定

 @ サブインターフェースの作成
 先ずルータでサブインターフェースを作成します。インターフェースコマンドで物理インターフェースの
 物理ポート番号の後にピリオド (
. ) と論理番号を設定します。論理番号の数字に意味はなく何番でもOK。
 ただし一般的には分かりやすさの観点から、論理番号の値とVLAN IDの値を同じにしておくことが多いです。

 
◆ サブインターフェースの作成
 (config)#
interface interface-type.subinterface-number

コマンド引数 説明
interface-type

 物理インターフェースのタイプと番号を指定

subinterface-number

 サブインターフェースの論理番号の指定

設定例

 (config)# interface FastEthernet0/0.1 ← Fa0/0 に論理番号 1 を付けたサブインターフェース



 A カプセル化タイプの指定、VLAN IDの指定
 次に作成したサブインターフェースで使用する
カプセル化VLAN IDを指定します。カプセル化タイプには
 
isldot1q があります。ここで設定するVLAN IDは、スイッチ上で設定しているVLAN IDに合わせます。

 
◆ カプセル化タイプとVLAN IDの指定
 (config-subif)#
encapsulation [ isl | dot1q ] vlan-id | native

コマンド引数 説明
isl

 ルータの物理ポートと接続するスイッチポートで、トランキングプロトコルがISLの場合に指定。

dot1q

 ルータの物理ポートと接続するスイッチポートで、トランキングプロトコルがIEEE802.1Qの場合に指定。

vlan-id

 スイッチ上で設定しているVLAN IDと同じ値に指定。

native  スイッチ上で設定しているVLAN IDがネイティブVLANの場合に指定。(dot1qの時に使用するコマンド)
設定例  (config-subif)# encapsulation dot1q 10 ← カプセル化をIEEE802.1Q、VLAN IDを10 に指定。



 B IPアドレッシングの設定
 最後に、作成したサブインターフェースにIPアドレスの設定を行います。

 
◆ IPアドレッシングの設定
 (config-subif)#
ip address ip-address subnet-mask

コマンド引数 説明
ip-address

 作成したサブインターフェースに対して設定するIPアドレス

subnet-mask  作成したサブインターフェースに対して設定するサブネットマスク
設定例  (config-subif)# ip address 192.168.10.254 255.255.255.0


 ◆ サブインターフェースの設定例(ISLの場合)

 トランクリンクがISLの場合、ネイティブVLANの概念はなく、全てのVLANに対してタグ付けを行います。
 従って、ISLの場合は
native キーワードは使用しません。設定例とコンフィグは以下の通りとなります。


      


 Router(config) #
interface FastEthernet0/0.1
 Router(config-subif) # encapsulation isl 1

 Router(config-subif) # ip address 192.168.1.254 255.255.255.0

 Router(config) #
interface FastEthernet0/0.2
 Router(config-subif) # encapsulation isl 2

 Router(config-subif) # ip address 192.168.2.254 255.255.255.0

 Router(config) # interface FastEthernet0/0.3
 Router(config-subif) # encapsulation isl 3

 Router(config-subif) # ip address 192.168.3.254 255.255.255.0


 
Switch(config) # interface FastEthernet0/24
 Switch(config-if) # switchport trunk encapsulation isl
 Switch(config-if) # switchport mode trunk




 ◆ サブインターフェースの設定例(IEEE802.1Q の場合)

 トランクリンクがIEEE802.1Qの場合、ネイティブVLANに対してはnativeキーワードを定義する必要が
 あります。下図はネイティブVLANが 1 の前提とします。設定例とコンフィグは以下の通りとなります。



      



 
Router(config) # interface FastEthernet0/0.1
 Router(config-subif) # encapsulation dot1q 1 native

 Router(config-subif) # ip address 192.168.1.254 255.255.255.0

 Router(config) # interface FastEthernet0/0.2
 Router(config-subif) # encapsulation dot1q 2

 Router(config-subif) # ip address 192.168.2.254 255.255.255.0

 Router(config) # interface FastEthernet0/0.3
 Router(config-subif) # encapsulation dot1q 3

 Router(config-subif) # ip address 192.168.3.254 255.255.255.0


 
Switch(config) # interface FastEthernet0/24
 Switch(config-if) # switchport trunk encapsulation dot1q
 Switch(config-if) # switchport mode trunk


 トランクリンクにIEEE802.1Qを使用する場合は、ルータの物理インターフェースをネイティブVLANと
 して使用することができます。当然、その他のVLANはサブインターフェースを使用する必要があります。
 上記と下記コンフィグは同じ内容、同じ動作となりますが、下記の設定は一般的な設定ではありません。


 
Router(config) # interface FastEthernet0/0
 Router(config-if) # ip address 192.168.1.254 255.255.255.0


 Router(config) # interface FastEthernet0/0.2
 Router(config-subif) # encapsulation dot1q 2

 Router(config-subif) # ip address 192.168.2.254 255.255.255.0

 Router(config) # interface FastEthernet0/0.3
 Router(config-subif) # encapsulation dot1q 3

 Router(config-subif) # ip address 192.168.3.254 255.255.255.0


 
Switch(config) # interface FastEthernet0/24
 Switch(config-if) # switchport trunk encapsulation dot1q
 Switch(config-if) # switchport mode trunk



 ◆ トラフィックの流れを理解しましょう!


     



 @ 正常時、端末A、B、C、Dの間で通信できます。つまりVLAN1〜VLAN3間で通信可能です。
 A 正常時でも、端末Eはどの端末とも通信できません。端末Eが他の端末と通信するためには
   ルータのFa0/0上でサブI/Fを作成して、VLANルーティングできるようにする必要があります。

 B SW Aがダウンした場合には、全ての端末( A、B、C、D )の間で通信できなくなります。
 C ルータ、またはルータのFa0/0がダウンした場合には、VLAN間の通信はできなくなります。
   ただし、VLAN内の通信については可能なので、端末BとCとの間は通信することができます。



ルータを使用したVLANルーティングとは

ネットワークエンジニアとして

Copyright (C) 2002-2020 ネットワークエンジニアとして All Rights Reserved.