WAN - DA / HSD / Serial / FR / ATM



 ◆ WAN - デジタルアクセス(DA / HSD)の設定

 IP-VPNのWANのアクセス回線としてNTT東西のデジタルアクセス(DA)を使用するコンフィグ設定例と
 デジタル専用線サービス(HSD)を使用するコンフィグ設定例は以下の通り。なつかしいコンフィグです。


    


 ◆ DA 64Kbpsで接続する場合の設定例

 Cisco(config)# ip cef

 Cisco(config)# isdn switch-type ntt
 Cisco(config)# isdn leased-line BRI0

 Cisco(config)# interface BRI0
 
Cisco(config-if)# no ip address

 Cisco(config)# interface BRI0:1
 Cisco(config-if)# ip address 192.168.0.1 255.255.255.252
 Cisco(config-if)# encapsulation ppp

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2



 ◆ HSD 128Kbpsで接続する場合の設定例

 Cisco(config)# ip cef

 Cisco(config)# isdn switch-type ntt
 Cisco(config)# isdn leased-line BRI0 128

 Cisco(config)# interface BRI0
 Cisco(config-if)# ip address 192.168.0.1 255.255.255.252
 Cisco(config-if)# encapsulation ppp

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2




 ◆ WAN - シリアルインターフェース接続の設定

 ルータのSerialポートを利用してTA(Terminal Adapter)と接続して128Kbpsで通信する場合の設定例。


      


 ◆ Serialインターフェース接続により128kbpsで通信する設定例

 Cisco(config)# ip cef

 Cisco(config)# interface Serial0/0/0
 Cisco(config-if)# ip address 192.168.0.1 255.255.255.252
 
Cisco(config-if)# bandwidth 128
 Cisco(config-if)# encapsulation ppp

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2



 ◆ WAN - 1.5Mbps(フラクショナルT1)接続の設定

 192kbps 〜 1.5Mbps専用線のDSUに対して、メタリックケーブルで接続可能なフラクショナルT1を
 利用して、1.5Mbpsで接続する場合の設定例は以下となります。


  


 ◆ フラクショナルT1 接続により1.5Mbpsで通信する設定例

 Cisco(config)# ip cef

 Cisco(config)# interface Serial0/0/0
 Cisco(config-if)# ip address 192.168.0.1 255.255.255.252
 Cisco(config-if)# encapsulation ppp
 
Cisco(config-if)# service-module t1 framing esf
 Cisco(config-if)# service-module t1 linecode b8zs
 
Cisco(config-if)# service-module t1 timeslots 1-24 speed 64

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2


設定コマンド 説明
service-module t1 framing esf  フレーム形式の指定。デジタルアクセス専用線を使用する場合 esf を指定。
service-module t1 linecode b8zs

 ラインコード形式の指定。デジタルアクセス専用線を使用する場合、b8zs を指定。
 ※ ラインコード形式とは、シリアルライン上での伝送路符号化形式のこと。

service-module t1 timeslots 1-24

 アクセス回線速度の指定。回線速度の帯域は各タイムスロットのチャネル範囲の
 合計値になる。タイムスロットとはPRI(1.544Mbps)を、Bチャネル(64kbsp)
 単位で24分割したもの。各回線速度の設定は以下のように設定する。


回線速度 設定コマンド
192 Kbps service-module t1 timeslots 1-3 speed 64
256 Kbps service-module t1 timeslots 1-4 speed 64
384 Kbps service-module t1 timeslots 1-6 speed 64
512 Kbps service-module t1 timeslots 1-8 speed 64
768 Kbps service-module t1 timeslots 1-12 speed 64
1 Mbps service-module t1 timeslots 1-16 speed 64
1.5 Mbps service-module t1 timeslots 1-24 speed 64



 PRIのI/Fを使用する場合のコンフィグ例です。チャナライズドT1の場合はカードタイプを指定する必要が
 あり、今回の設定例ではT1インターフェースがSlot 1に接続しているので、スロット1にカードタイプT1を
 指定します。また、回線速度を設定する際にはservice-moduleではなく、channel-groupコマンドで指定。


   


 ◆ フラクショナルT1 接続により1.5Mbpsで通信する設定例


 Cisco(config)# ip cef
 Cisco(config)# card type t1 1

 Cisco(config)# controller T1 1/0
 Cisco(config-controller)# framing esf
 Cisco(config-controller)# linecode b8zs
 
Cisco(config-controller)# cablelength long 0db
 
Cisco(config-controller)# channel-group 1 timeslots 1-24 speed 64

 Cisco(config)# interface Serial 1/0:0
 Cisco(config-if)# ip address 192.168.0.1 255.255.255.252
 Cisco(config-if)# encapsulation ppp

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2


回線速度 設定コマンド
192 Kbps channel-group 1 timeslots 1-3 speed 64
256 Kbps channel-group 1 timeslots 1-4 speed 64
384 Kbps channel-group 1 timeslots 1-6 speed 64
512 Kbps channel-group 1 timeslots 1-8 speed 64
768 Kbps channel-group 1 timeslots 1-12 speed 64
1 Mbps channel-group 1 timeslots 1-16 speed 64
1.5 Mbps channel-group 1 timeslots 1-24 speed 64


 ◆ WAN - 128KbpsのFRアクセスタイプ接続の設定

 WANサービスはIP-VPNですが、アクセス回線にFRアクセスタイプ(128Kbps)を利用した場合の設定例。
 ※ LMIタイプはQ.933 Annex Aを指定するために、frame-relay lmi-type q933a と設定します。


   

 ◆ FRアクセスタイプ128kbpsで通信する設定例

 Cisco(config)# ip cef

 Cisco(config)# isdn switch-type ntt
 Cisco(config)# isdn leased-line BRI0 128

 Cisco(config)# interface BRI0
 Cisco(config-if)# no ip address
 Cisco(config-if)# encapsulation frame-relay IETF
 Cisco(config-if)# frame-relay lmi-type q933a

 Cisco(config)# interface BRI0.1 point-to-point
 Cisco(config-subif)# ip address 192.168.0.1 255.255.255.252
 Cisco(config-subif)# frame-relay interface-dlci 16

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2




 ◆ WAN - 1MbpsのATMアクセスタイプ接続の設定

 アクセス回線にNTT東西のATMメガリンクを使用した場合の設定例です。※ 契約帯域が1Mbpsとします。
 VPI(Virtual Channel Identifier)値は 0、VCI(Virtual Channel Identifier)値は 32、F5 OAMは利用
 しない設定とします。F5 OAMはF5 OAM Loopbackセルを利用してWAN回線の正常性を確認する保守機能。


    


 ◆ ATMアクセスタイプ1Mbpsで接続する場合の設定例

 Cisco(config)# ip cef

 Cisco(config)# interface ATM1/0
 Cisco(config-if)# no ip address
 Cisco(config-if)# atm sonet stm-1
 Cisco(config-if)# no atm ilmi-keepalive

 Cisco(config)# interface ATM1/0.1 point-to-point
 Cisco(config-subif)# ip address 192.168.0.1 255.255.255.252
 Cisco(config-subif)# pvc 0/32
 Cisco(config-subif-atm-vc)# vbr-nrt 1000 1000
 Cisco(config-subif-atm-vc)# encapsulation aal5snap

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2


設定コマンド 説明
atm sonet stm-1

 SONETフレーミングとしてSTM-1を指定。デフォルト値はSTS-3cとなる。
 ※ STM-1 : セルレートデカップリング用にアイドルセルを送信。
 ※ STS-3c : セルレートデカップリング用に未指定セルを送信。

no atm ilmi-keepalive  ATM ILMI KeepAliveの送出間隔の指定。この設定では無効化している。
pvc 0/32  PVCのVPI / VCI を設定する。
vbr-nrt 1000 1000  PVCにおける出力PCR(Peak Cell Rate)、SCR(Sustainable Cell Rate)を指定する。
encapsulation aal5snap  ATMレイヤーAAL5、LLC SNAPでカプセル化するための設定



 F5 OAM Loopbackセルを利用する場合、CEルータ⇔PEルータ間のアクセス回線区間の正常性を確認可。

 ◆ ATMアクセスタイプ1Mbpsで接続する場合の設定例 - F5 OAM Loopbackセルの利用

 Cisco(config)# ip cef

 Cisco(config)# interface ATM1/0
 Cisco(config-if)# no ip address
 Cisco(config-if)# atm sonet stm-1
 Cisco(config-if)# no atm ilmi-keepalive

 Cisco(config)# interface ATM1/0.1 point-to-point
 Cisco(config-subif)# ip address 192.168.0.1 255.255.255.252
 Cisco(config-subif)# pvc 0/32
 Cisco(config-subif-atm-vc)# vbr-nrt 1000 1000
 Cisco(config-subif-atm-vc)# oam-pvc manage 10
 Cisco(config-subif-atm-vc)# oam retry 3 5 1
 Cisco(config-subif-atm-vc)# encapsulation aal5snap

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2


設定コマンド 説明
oam-pvc manage 10

 OAM Loopbackセル機能とOAM/PVC管理を有効にします。この設定では
 Loopbackセルの送出間隔は10秒となる。ちなみに、障害を検知した場合は
 PVC Stateは"Not Verified"となる.。

oam retry 3 5 1

 OAMリトライのパラメータの定義
 3 : OAM retry count before declaring a VC is up
 5 : OAM retry count before a VC is declared down
 1 : OAM retry polling frequency





 ◆ 付録 : ISDNのダイヤルアップによるインターネット接続

 上記で紹介したIP-VPNサービスとは全く関係のない、ISDNダイヤルアップ接続のルータの設定例です。


 Cisco(config)# ip cef

 Cisco(config)# isdn switch-type ntt

 Cisco(config)# interface BRI0
 Cisco(config-if)# no ip address
 Cisco(config-if)# encapsulation ppp
 
Cisco(config-if)# dialer pool-member 1
 Cisco(config-if)# isdn switch-type ntt
 Cisco(config-if)# isdn point-to-point-setup

 Cisco(config)# interface Dialer1
 Cisco(config-if)# ip address negotiated
 Cisco(config-if)# ip nat outside
 
Cisco(config-if)# encapsulation ppp
 Cisco(config-if)# dialer pool 1
 Cisco(config-if)# dialer idle-timeout 60
 
Cisco(config-if)# dialer string XXXXXXXXXX
 
Cisco(config-if)# dialer-group 1
 
Cisco(config-if)# ppp authentication chap callin
 
Cisco(config-if)# ppp chap hostname xxxx@xxx.com
 
Cisco(config-if)# ppp chap password xxxxx

 Cisco(config)# ip nat inside source list 101 interface Dialer1 overload

 Cisco(config)# access-list 101 permit ip any any
 Cisco(config)# dialer-list 1 protocol ip permit

 Cisco(config)# ip route 0.0.0.0 0.0.0.0 192.168.0.2



 ◆ ISDNダイヤルアップ接続 - 確認コマンド
Ciscoコマンド 取得できる情報
 show interfaces dialer 1  ダイヤラーインターフェースの状態、BRIインターフェースのBチャネルの状態
 show isdn status  ISDNの接続状態の確認
 show isdn active  現在のコールの情報を表示
 show ip nat translations  現在アクティブなNATテーブルまたはPATテーブルの表示



インターネット接続 - PPPoE(端末型払い出し)ASA5505 設定例

ネットワークエンジニアとして

Copyright (C) 2002-2021 ネットワークエンジニアとして All Rights Reserved.