PPPoE Server - Cisco Config



 ◆ CiscoルータをPPPoEサーバにする設定

 Ciscoルータでは、PPPoEクライアントだけでなく、PPPoEサーバになることができます。PPPoE回線
 がなくてもCiscoルータをPPPoEサーバに設定することで、PPPoE接続環境での検証が可能となります。


      


設定項目 説明
 PPPoE接続の認証ユーザ  test1@example.com
 PPPoE接続の認証パスワード  Cisco123
 PPPoEサーバのIPアドレス  20.1.1.1/32( PPPoEクライアントのルーティングテーブルでも表示 )
 PPPoEクライアントのIPアドレス  10.1.1.1/32( PPPoEクライアントのルーティングテーブルでも表示 )



 ◆ PPPoEサーバ :設定例

 hostname PPPoE-SV1

 username test1@example.com password Cisco1

 ip local pool POOL1 10.1.1.1

 interface Loopback1
 ip address 20.1.1.1 255.255.255.255

 interface Virtual-Template1
 mtu 1454
 ip unnumbered Loopback1
 peer default ip address pool POOL1
 ppp authentication chap

 bba-group pppoe PPPOE-GROUP1
 virtual-template 1

 interface GigabitEthernet 0
 no ip address
 pppoe enable group PPPOE-GROUP1
 no shutdown


 ◆ PPPoEクライアント:設定例

 hostname PPPoE-CL1

 interface GigabitEthernet0
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
 no shutdown

 interface Dialer1
 ip address negotiated
 ip mtu 1454
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname test1@example.com
 ppp chap password Cisco1

 dialer-list 1 protocol ip permit

 ip route 0.0.0.0 0.0.0.0 dialer1




 PPPoE-CL1#show ip route
 S*  0.0.0.0/0 is directly connected, Dialer1
    10.0.0.0/32 is subnetted, 1 subnets
 C  10.1.1.1 is directly connected, Dialer1
    20.0.0.0/32 is subnetted, 1 subnets
 C  20.1.1.1 is directly connected, Dialer1


 PPPoEクライアントのルータでは、10.1.1.1と20.1.1.1にPINGを実行すると両方ともに応答があります。


 ※ 以下メッセージが繰り返される場合、PPPoEサーバとクライアントとで設定しているユーザ名とパスワードが一致していません。
 %DIALER-6-BIND: Interface Vi1 bound to profile Di1
 %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
 %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
 %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down



ネットワークエンジニアとして

Copyright (C) 2002-2021 ネットワークエンジニアとして All Rights Reserved.