MHSRP ( Multiple HSRP )



 ◆ MHSRP(Multiple HSRP)の設定

 HSRPではセグメントごとに1つのHSRPグループを作成して1台をアクティブ、もう1台をスタンバイと
 して動作させていましたが、
セグメントごとに複数のHSRPグループを作成することも可能です。この
 HSRP設定を
MHSRPと言います。MHSRPにより1つのセグメント上で1つのルータがあるグループでは
 アクティブにトラフィックを転送して、別のグループにおいてはスタンバイ状態になることができます。

 下図では、SW1はHSRPグループ「1」ではアクティブルータ、「2」ではスタンバイルータとなります。
 その一方、SW2はHSRPグループ「1」ではスタンバイルータ、「2」ではアクティブルータとなります。
 ここでロードバランスさせる前提は、下図のようにPC側でIPアドレスごとに異なるGWを設定すること。
 172.16.5.10〜120 は「172.16.5.253」を指定して、172.16.5.121〜240 は「172.16.5.254」を指定。


   


 ◆ SW1 - コンフィグ設定

 SW1(config) #
interface gigabitethernet1/0/1
 SW1(config-if) # no switchport
 SW1(config-if) # ip address 172.16.5.1 255.255.255.0
 SW1(config-if) # standby 1 ip 172.16.5.253
 SW1(config-if) # standby 1 priority 105
 SW1(config-if) # standby 1 preempt
 SW1(config-if) # standby 2 ip 172.16.5.254
 SW1(config-if) # standby 2 preempt



 ◆ SW2 - コンフィグ設定

 SW1(config) #
interface gigabitethernet1/0/1
 SW1(config-if) # no switchport
 SW1(config-if) # ip address 172.16.5.2 255.255.255.0
 SW1(config-if) # standby 1 ip 172.16.5.253
 SW1(config-if) # standby 1 preempt
 SW1(config-if) # standby 2 ip 172.16.5.254
 SW1(config-if) # standby 2 priority 105
 SW1(config-if) # standby 2 preempt



 ◆ HSRP - 負荷分散の設定

 MHSRPの実装は、現在の企業ネットワークではあまり使用されません。なぜなら、MHSRPによって
 セグメント内で負荷分散させるよりも、セグメントごとに負荷分散させるほうが運用管理的に優れて
 いるからです。下図では、「VLAN1ではSW1をアクティブルータ」「VLAN2ではSW2をアクティブ
 ルータ」としています。なお、STPのルートブリッジはHSRPのアクティブ側になるように設定します。


  


 ◆ SW1 - コンフィグ設定

 SW1(config) # spanning-tree vlan 1 priority 0
 SW1(config) #
spanning-tree vlan 2 priority 4096

 SW1(config) #
interface vlan 1
 SW1(config-if) # ip address 172.16.1.1 255.255.255.0
 SW1(config-if) # standby 1 ip 172.16.1.254
 SW1(config-if) # standby 1 priority 105
 SW1(config-if) # standby 1 preempt

 SW1(config) # interface vlan 2
 SW1(config-if) # ip address 172.16.2.1 255.255.255.0
 SW1(config-if) # standby 2 ip 172.16.2.254
 SW1(config-if) # standby 2 preempt


 ◆ SW2 - コンフィグ設定

 SW2(config) # spanning-tree vlan 1 priority 4096
 SW2(config) #
spanning-tree vlan 2 priority 0

 SW2(config) #
interface vlan 1
 SW2(config-if) # ip address 172.16.1.2 255.255.255.0
 SW2(config-if) # standby 1 ip 172.16.1.254
 SW2(config-if) # standby 1 preempt

 SW2(config) # interface vlan 2
 SW2(config-if) # ip address 172.16.2.2 255.255.255.0
 SW2(config-if) # standby 2 ip 172.16.2.254
 SW2(config-if) # standby 2 priority 105
 SW2(config-if) # standby 2 preempt



 ※ 現在の主流なL3スイッチの冗長化は、HSRPを使用するのではなくスタック構成による実装が一般的です。



HSRP(インターフェース、オブジェクトトラッキング)設定 VRRPとは

ネットワークエンジニアとして

Copyright (C) 2002-2020 ネットワークエンジニアとして All Rights Reserved.