HSRP - interface tracking / object tracking



 ◆ HSRP - インターフェーストラッキング設定

 HSRPを有効にしていないインターフェースがダウンした時に、HSRPを有効にしているインターフェースの
 HSRPプライオリティ値を小さくして、アクティブルータを切り替える機能を
インターフェーストラッキング
 と言います。例えば、HSRPを有効にしたLAN側 I/F だけがアクティブ状態でも、同じルータのWAN側 I/Fが
 アクティブでなければ通信が継続しないので、トラッキング( 追跡 )することによって通信を継続できます。


  


 ◆ HSRPのインターフェーストラッキングの設定
 (config-if)#
standby group-number track
interface-number interface-priority

コマンド引数 説明
interface-number

 トラッキング(追跡)対象のインターフェースを指定。

interface-priority


 トラッキング(追跡)対象のインターフェースを指定した時の減算値を指定。指定しないとデフォルトで
 
10が減算される。トラッキング対象のインターフェースがアップ状態になればこの指定値が加算される。
 設定例:追跡対象のインターフェースに「GigabitEthernet0/0」を指定して、減算値「10」とする。

 (config-if)# standby 1 track GigabitEthernet0/0




 ◆ SW1 - コンフィグ設定

 SW1(config) #
interface vlan 5
 SW1(config-if) # ip address 172.16.5.1 255.255.255.0
 SW1(config-if) # standby 5 ip 172.16.5.254
 SW1(config-if) # standby 5 priority 105
 SW1(config-if) # standby 5 preempt
 SW1(config-if) # standby 5 track GigabitEthernet0/0



 ◆ SW2 - コンフィグ設定

 SW2(config) #
interface vlan 5
 SW2(config-if) # ip address 172.16.5.2 255.255.255.0
 SW2(config-if) # standby 5 ip 172.16.5.254
 SW1(config-if) # standby 5 priority 100
 SW1(config-if) # standby 5 preempt

  現在では、この「インターフェーストラッキング」ではなく、以下の「オブジェクトトラッキング」を使用するのが一般的です。


 ◆ HSRP - オブジェクトトラッキング設定

 オブジェクトトラッキングでは、インターフェース状態だけでなくルーティング状態などを見てHSRPの
 切替りを実現することも可能です。オブジェクトトラッキングのコマンド引数は非常に多いので、今回は
 よく使用される2つのオブジェクトトラッキングを紹介します。

 ◆ インターフェースのラインプロトコルやIPルーティングが有効かどうかを追跡
 (config)#
track object-number interface interface-id line-protocol | ip routing

 ◆ IP SLAのIPリーチャビリティがあるかどうかを追跡、遅延やジッタなどの追跡
 (config)# track object-number ip sla number [ state | reachability ]


 上記コマンドで追跡対象を指定した後、オブジェクトトラッキングを以下のコマンドでHSRPへ適用。

 
◆ オブジェクトトラッキングのHSRPグループへの適用
 (config-if)# standby group-number track object-number
decrement value


 以下の設定例では、GigabitEthernet0/0 のインターフェースの「 ラインプロトコルが有効かどうか 」
 つまり「GigabitEthernet0/0のインターフェースが正常に使用できる状態であるか」と、100.1.1.1の
 あて先にPINGを実行して応答があるかどうかを、つまり「正常時のパスが正常であるかどうか」の2つを
 トラッキングしている設定例。設定例の理解のために IP SLAIP SLA - 設定コマンド もご参考下さい。


  

 ◆ SW1 - コンフィグ設定例

 SW1(config)# ip sla 1
 SW1(config-ip-sla)# icmp-echo 192.168.1.1 source-interface vlan 5
 SW1(config-ip-sla)# frequency 10
 SW1(config)# ip sla schedule 1 life forever start-time now

 SW1(config) # track 101 interface GigabitEthernet0/0 line-protocol
 SW1(config) #
track 102 ip sla 1 reachability

 SW1(config) #
interface vlan 5
 SW1(config-if) # ip address 172.16.5.1 255.255.255.0
 SW1(config-if) # standby 5 ip 172.16.5.254
 SW1(config-if) # standby 5 priority 105
 SW1(config-if) # standby 5 preempt
 SW1(config-if) # standby 5 track 101
 SW1(config-if) # standby 5 track 102


 ◆ SW2 - コンフィグ設定例

 SW2(config) #
interface vlan 5
 SW2(config-if) # ip address 172.16.5.2 255.255.255.0
 SW2(config-if) # standby 5 ip 172.16.5.254
 SW1(config-if) # standby 5 priority 100
 SW1(config-if) # standby 5 preempt




HSRP( Hello/Holdタイマー、preempt delay、認証 )設定 HSRP( MHSRP、負荷分散 )設定

ネットワークエンジニアとして

Copyright (C) 2002-2020 ネットワークエンジニアとして All Rights Reserved.