EtherChannel - L3 EtherChannel Configuration



 ◆ L3 EtherChannel の設定

 Layer3 EtherChannel の設定は、EtherChannelを形成したい物理ポートに
channel-groupコマンドを
 設定する必要があります。L3として動作させるので、ルーティングの有効化とルーテッドポートの設定
 が必要となります。また、interface PortChannel に対してIPアドレスを割り当てる必要があります。


 
◆ L3 EtherChannel の設定
 (config)#
ip routing

 (config)# interface interface-id
 (config-if)#
no switchport
 (config-if)#
channel-group group-number mode [ auto | desirable | on | active | passive ]

 (config)# interface port-channel port-channel-id
 (config-if)#
no switchport
 (config-if)# ip address address mask
 (config-if)#
no shutdown

コマンド引数 説明
group-number

 ポートチャネル論理インターフェースの番号。1 〜 48 で指定。

auto


 PAgPを有効化して、パッシブネゴシエーションを行う。自身のポートを auto にした場合、
 対向のポートを desirable にする必要がある。auto の設定は以下。

 (config-if)# channel-group 1 mode auto

desirable


 PAgPを有効化して、アクティブネゴシエーションを行う。自身のポートを desirable にした場合、
 対向のポートは auto でも desirable の設定でも動作する。desirableの設定は以下。

 (config-if)# channel-group 1 mode desirable

on


 PAgPやLACPを使用せずに、スタティックで強制的にチャネル化する設定。on の設定は以下。

 (config-if)# channel-group 1 mode on

passive


 LACPを有効化して、パッシブネゴシエーションを行う。自身のポートを passive にした場合、
 対向のポートを active にする必要がある。passiveの設定は以下。

 (config-if)# channel-group 1 mode passive

active


 LACPを有効化して、アクティブネゴシエーションを行う。自身のポートを active にした場合、
 対向のポートは activeでも passive の設定でも動作する。activeの設定は以下。

 (config-if)# channel-group 1 mode active




         


 
◆ L3 EtherChannel の設定例 - SWA


 Catalyst(config) # ip routing

 Catalyst(config) # interface range gigabitethernet 1/0/23 -24
 Catalyst(config-if-range) #
no switchport
 Catalyst(config-if-range) # channel-group 10 mode on

 Catalyst(config) # interface port-channel 10
 Catalyst(config-if) #
no switchport
 Catalyst(config-if) # ip address 172.16.1.1
 Catalyst(config-if) #
no shutdown


 ◆ L3 EtherChannel の設定例 - SWB


 Catalyst(config) # ip routing

 Catalyst(config) # interface range gigabitethernet 1/0/23 -24
 Catalyst(config-if-range) #
no switchport
 Catalyst(config-if-range) # channel-group 10 mode on

 Catalyst(config) # interface port-channel 10
 Catalyst(config-if) # no switchport
 Catalyst(config-if) # ip address 172.16.1.2
 Catalyst(config-if) #
no shutdown



 ※ 以下の内容は「 L2 EtherChannel - コンフィグ設定 」の解説内容と同じです。


 ◆ ロードバランスの設定

 ロードバランス方式は、
port-channel load-balanceコマンドで設定変更が可能です。デフォルト値は
 ボックス型のCatalystの場合は「src-mac」であり、汎用的で最適なロードバランス方式であることから
 基本的に変更する必要はありませんが、通信要件に応じて変更する必要がある場合にはこの値を変えます。

 ◆ ロードバランス方式の設定
 (config)# port-channel load-balance dst-ip | dst-mac | src-dst-ip | src-dst-mac | src-ip | src-mac

 それぞれのコマンドの意味は「 EtherChannel - ロードバランス方式 」をご参照頂ければと思います。なお
 現在のロードバランス方式の状態は show etherchannel load-balance コマンドで確認することができます。



 ◆ EtherChannel - ステータス確認コマンド

ステータス確認コマンド 説明
 show etherchannel summary  interface Port-Channelにどの物理ポートがバンドルされているかを確認
 show etherchannel detail  上記の summary コマンドより詳細に Port-Channel ステータスを確認
 show etherchannel load-balance  EtherChannelにおける現在のロードバランス方式が何であるのかを確認
 show lacp neighbor  LACPにより形成したEtherChannelで隣接するスイッチのポート情報を確認
 show pagp neighbor  PagPにより形成したEtherChannelで隣接するスイッチのポート情報を確認



L2 EtherChannel - コンフィグ設定 EtherChannel - PAgP・LACPの詳細設定

ネットワークエンジニアとして

Copyright (C) 2002-2024 ネットワークエンジニアとして All Rights Reserved.