Cisco Nexus - config sample 2



 ◆ Nexus5500/5600 ⇔ Nexus2000 vPC/FEX/HSRP設定 その2

 ※ 検証機器はNexus5500を使用していますが、本内容はNexus5600にも適用できる設定例です。


   



 以下のコンフィグ設定例は、N5500 ⇔ N2000 vPC/FEX/HSRP設定 その1 の内容の続きとなります。以下
 のコンフィグ設定前に上記リンク先の設定に従って、vPCなどの基本設定を完了させるようにしましょう。
 Nexus5500については、Nexus5548を使用してNexus2000についてはN2K-C2248TP-1GEを使用すること
 を前提として、設定例を紹介します。


 ◆ FEXの設定 その1

 
◇ N5K-1 のコンフィグ

 feature fex

 interface Ethernet1/1
  switchport mode fex-fabric
  fex associate 101
  channel-group 101

 interface port-channel101
  vpc 101

 interface Ethernet1/2
  switchport mode fex-fabric
  fex associate 102
  channel-group 102

 interface port-channel102
  vpc 102


 ◇ N5K-2 のコンフィグ

 feature fex

 interface Ethernet1/1
  switchport mode fex-fabric
  fex associate 101
  channel-group 101

 interface port-channel101
  vpc 101

 interface Ethernet1/2
  switchport mode fex-fabric
  fex associate 102
  channel-group 102

 interface port-channel102
  vpc 102



 ◆ FEXの設定 その2

 
◇ N5K-1 のコンフィグ

 interface Ethernet101/1/1
  switchport access vlan 101
  spanning-tree port type edge

 interface Ethernet101/1/1
  switchport access vlan 101
  spanning-tree port type edge


 interface Ethernet102/1/1
  switchport access vlan 101
  spanning-tree port type edge

 interface Ethernet102/1/2
  switchport access vlan 102
  spanning-tree port type edge


◇ N5K-2 のコンフィグ

 interface Ethernet101/1/1
  switchport access vlan 101
  spanning-tree port type edge

 interface Ethernet101/1/1
  switchport access vlan 101
  spanning-tree port type edge


 interface Ethernet102/1/1
  switchport access vlan 101
  spanning-tree port type edge

 interface Ethernet102/1/2
  switchport access vlan 102
  spanning-tree port type edge


 サーバをリンクアグリゲーション接続して拡張vPCを実装する場合、拡張 (Enhanced) vPCをご参考下さい。


 
◆ FEXの設定 その3

 
◇ N5K-1 のコンフィグ

 fex 101
  type N2248T

 fex 102
  type N2248T


◇ N5K-2 のコンフィグ


 fex 101
  type N2248T

 fex 102
  type N2248T


 fexコンフィグレーション後にpinning max-links 1というコマンドが自動的に設定されます。FEX接続では
 Static Pinning と Port-Channelの大きく2つの接続方式がありますが、今回の構成(一般的な構成)では、
 Port-Chanelを使用するので、論理的なアップリンクが1つであることを意味する pinning max-links 1 でOK。
 ※ Static Pinningで実装したい場合は、このpinning max-links "1"の値を変更して設計/設定を行います。

 FEX接続が正常に完了すると、show fexコマンドで、FEX StateがOnlineとして確認することができます。
 FEX接続後は、show fex、show fex detail、show interface fex-fabircコマンドでステータス確認します。


 
◆ HSRPの設定

 
◇ N5K-1 のコンフィグ

 feature hsrp

 interface Vlan101
  no shutdown
  hsrp version 2
  hsrp 101
   preempt
   priority 105
   timers 1 3
   ip 192.168.101.254

 interface Vlan102
  no shutdown
  hsrp version 2
  hsrp 102
   preempt
   priority 105
   timers 1 3
   ip 192.168.102.254


 ◇ N5K-2 のコンフィグ

 feature hsrp

 interface Vlan101
  no shutdown
  hsrp version 2
  hsrp 101
   preempt
   timers 1 3
   ip 192.168.101.254

 interface Vlan102
  no shutdown
  hsrp version 2
  hsrp 102
   preempt
   timers 1 3
   ip 192.168.102.254





 ◆ 参考 : FEXのPre-Provisioning機能の設定

 FEXの各ポートのコンフィグレーションは、FEXが"online"状態にならなければ設定できませんが、以下の
 provision modelコマンドで該当機種を指定することで、FEXが接続していない状態でも事前にコンフィグの
 設定が可能です。provision modelコマンドを設定しておくことでNexus親スイッチのハードウェアの障害時
 にスムーズに交換作業が行えます。保守チームのことを考えると必ず設定しておくべきコマンドと言えます。

 
◇  設定例 : Slot 101 に接続予定のN2K-C2232TM、Slot 102 に接続予定の N2K-C2248TP-E-1GE を Pre-Provision

 Nexus(confg)# fex 101
 Nexus(confg)# fex 102

 
Nexus(confg)# slot 101
 Nexus(config-slot)# provision model N2K-C2232TM

 Nexus(confg)# slot 102
 Nexus(config-slot)# provision model N2K-C2248TP-E-1GE


 ※ 本設定により、例えば interface ethernet101/1/1 や interface ethernet102/1/1 ポートの設定が行えるようになります。



Cisco Nexus - コンフィグ設定

ネットワークエンジニアとして

Copyright (C) 2002-2019 ネットワークエンジニアとして All Rights Reserved.